I installed PGI on our new server (RHEL 6.6) and successfully started the license manager; hut when I run a PGI compiler, I got this error message:

pgi-f95-lin32: LICENSE MANAGER PROBLEM: Failed to checkout license
pgi-f95-lin32: LICENSE MANAGER PROBLEM: Invalid host.
The hostid of this system does not match the hostid
specified in the license file.
Feature: pgi-f95-lin32
Hostid: b083fed5855e
License path: /usr/local/pgi/license.dat:
FLEXnet Licensing error:-9,57

The “lmutil hostid” commnad shows the above hostid is the correct one:

The FlexNet host ID of this machine is "“b083fed5855e b083fed58560 b083fed58562 b083fed58564 80000048fe80"”

The internet search indicates that this may be caused by our new server network ports named as em1, em2, etc instead of eth0, eth1 …

How to get the PGI’s license manager works with “em” port names?


If you are using the lmgrd and pgroupd that came with the same release
that you ran
% lmutil lmhostid
and it returns b083fed5855e as one of the values, the license should work.

Older lmgrd versions may not find your newer hostids.

also if
% lmutil lmhostid -hostname
returns “HOSTNAME=meta”
then meta is a good hostname to use.

Your current license

SERVER meta b083fed5855e 27000
DAEMON pgroupd
PACKAGE PGI2015-507267 pgroupd 2015.1231 F4B26871B7CD
COMPONENTS="pgi-hpf-lin64 pgi-f95-lin64 pgi-f77-lin64 \

But if you have a laptop, you will sometimes be on Ethernet,
sometimes wifi, and sometimes no network.

Run “lmutil lmhostid” and “lmutil lmhostid -hostname” in all
three environments and see what comes out. Some hostids may vanish,
and sometimes

% ping meta

is not defined (which could be a problem).

Suggest you add ‘localhost’ to /etc/hosts, and give it IPadrress

Then edit the license manually and change meta to localhost.

localhost should work everywhere as a hostname, and using a hostid
that persists everywhere should be okay.

If you still have problems, send the outputs of

% lmutil lmhostid
% lmutil lmhostid -hostname
% lmutil lmhostid -internet
% ping meta
% /sbin/ifconfig

to , and we can go from there.


This server doesn’t have WiFi port. It has four Ethernet ports and one InfiniBand port. I double checked hostid, hostname, etc. Everything looks correct. I’ll send those outputs to Thanks.

Out of the four Ethernet ports, only em3 and em4 are connected. The IP address associated with the hostname meta is on em3. The PGI license was obtained with hostid of the em1 port. Could this cause the problem of mismatching hostid?

If you run
% /sbin/ifconfig

one of the network devices should have an inet4 address that is the
same as

% ping meta

and that is the best hostid to use - the MAC of the device tied to
the IPaddress mapped to the name ‘meta’

Bridges and Tunnels on network devices can confuse the license service.
You might try the license service when they are down, if you have them,
and see if the service works.


I obtained a new license data file with the hostid (b083fed58562) matching MAC # of the network port em3 that has the IP address ( associated with the host name (meta); but it still doesn’t work - same error message: “The hostid of this system does not match the hostid specified in the license file.”

Here is the output of “ip add”:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: em1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
link/ether b0:83:fe:d5:85:5e brd ff:ff:ff:ff:ff:ff
3: em2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
link/ether b0:83:fe:d5:85:60 brd ff:ff:ff:ff:ff:ff
4: em3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
link/ether b0:83:fe:d5:85:62 brd ff:ff:ff:ff:ff:ff
inet brd scope global em3
inet6 fe80::b283:feff:fed5:8562/64 scope link
valid_lft forever preferred_lft forever
5: em4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
link/ether b0:83:fe:d5:85:64 brd ff:ff:ff:ff:ff:ff
inet brd scope global em4
inet6 fe80::b283:feff:fed5:8564/64 scope link
valid_lft forever preferred_lft forever
6: ib0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 2044 qdisc pfifo_fast state UP qlen 256
link/infiniband 80:00:00:48:fe:80:00:00:00:00:00:00:00:02:c9:03:00:4a:f5:43 brd 00:ff:ff:ff:ff:12:40:1b:ff:ff:00:00:00:00:00:00:ff:ff:ff:ff
inet brd scope global ib0
inet6 fe80::202:c903:4a:f543/64 scope link
valid_lft forever preferred_lft forever

I have just sent mail to the address associated with W.Z.
and it contains a temp license and a permanent license.

The temp license will verify the hostid you use will work
in the permanent license.

If the hostid works, then try the attached permanent license.

Tunnels, Bridges, and disconnected network cards can cause the
hostid to not be found at runtime. If it is not found by

% lmutil lmhostid

then it will never work. If it is detected, the license service should
run, and will fail if you are not pointing to the right license file
(% lmutil lmdiag will reveal which is read) or have
a bridged/tunneled/disconnected network card.


The problem is fixed. As I suspected at the beginning. The problem is caused by the network port names set as em1, em2 etc instead of eth0, eth1 … I renamed port name back to eth0, etc without changing anything regarding the PGI license. The license works OK now.

To boot the server to the default ethX network port names, add biosdevname=0 to the boot command line in grub.conf, rename ifcfg-emX to ifcfg-ethY in /etc/sysconfig/network-script, e.g. ifcfg-em3 ifcfg-eth2, and change DEVICE=“em3” to DEVICE=“eth2”.