Physx, CUDA are unavailable after using Remote Desktop


After I have enabled and tried using RDP (I won’t do that mistake again), all my games with physx can’t use GPU for physx effects. When I turn on Physx indicator, it always stays at CPU.

I have tried using Physx Fluid, and it only uses CPU, with Physx GPU greyed out.

In GPU-Z OpenCL, CUDE, PhysX are not ticked:

Steps I have tried so far:

  1. Uninstalled video drivers using Driver Sweeper tool, rebooted in safe mode, bla-bla.
    Installed the latest drivers with Physx ticked. No luck

  2. Uninstalled with Driver sweeper, did all that, then installed latest drivers only (without Physx, GeForce experience, etc). Installed latest Physx as a stand-alone. No luck.

  3. Uninstalled with Driver Sweeper, installed old drivers (from February). Then installed old Physx as a stand-alone package. No luck.

GPU-Z is still showing no CUDA or PhysX, games with Physx (Metro LL for example) run very bad (10 fps). Of course disabling physx in games solves the problem, but I still want Physx to work and use GPU, and CUDA to work as well. I have since disabled RDP, but that didn’t help. Any way to undo those changes (I don’t have any backups, can’t restore), and replace RDP drivers with NVidia ones?

Thank you very much.

1 Like

I have found a forum thread here:

Solution #1: restore Windows to a point when you didn’t have this problem

Solution #2: "I found out what disabled OpenCL + CUDA + PhysX!!!

When you disable TDR and set TdrLevel to 0 in the registry with a QWORD instead of a DWORD and reboot = BAM! no more goodies

this is simply retarded…"

I will try second solution, but something tells me it won’t help…

1 Like

Yep, solution 2 did the trick!

1 Like

unless you gave this brilliant solution I would have been spending more endless nights reinstalling drivers