Pinmux-dts2cfg.py errors with default pinmux

When using the default pinmux spreadsheet (V1.08) to generate a pinmux configuration for a TX2i I get the following errors when running pinmux-dts2cf.py.

python pinmux-dts2cfg.py --pinmux addr_info.txt gpio_addr_info.txt por_val.txt --mandatory_pinmux_file mandatory_pinmux.txt tegra18x-jetson-default-template-pinmux.dtsi tegra18x-jetson-default-template-gpio-default.dtsi 1.0 > ../../../bootloader/t186ref/BCT/tegra186-mb1-bct-pinmux-quill-p3489-1000-a00.cfg
ERROR: pin dap2_sclk_pc1(0x00000440) field nvidia,enable-input(0x00000040) is not matching, val = 0x01 expected = 0x00
ERROR: pin dap2_fs_pc4(0x00000440) field nvidia,enable-input(0x00000040) is not matching, val = 0x01 expected = 0x00
ERROR: pin dmic1_clk_pm1(0x00004441) field nvidia,enable-input(0x00000040) is not matching, val = 0x01 expected = 0x00
ERROR: pin dmic2_dat_pm2(0x00004441) field nvidia,enable-input(0x00000040) is not matching, val = 0x01 expected = 0x00
ERROR: pin dap4_sclk_pcc0(0x00004440) field nvidia,enable-input(0x00000040) is not matching, val = 0x01 expected = 0x00
ERROR: pin dap4_fs_pcc3(0x00004440) field nvidia,enable-input(0x00000040) is not matching, val = 0x01 expected = 0x00
ERROR: pin sdmmc4_dqs(0x00000444) field nvidia,tristate(0x00000010) is not matching, val = 0x00 expected = 0x01

hello rgalliath ,

please check the readme file, you should remove --mandatory_pinmux_file options for confirmation.
thanks

Hi Jerry,

Thanks that worked. Could you explain what the purpose of the mandatory_pinmux.txt file is? All the readme says is:

Mandatory pinmux information file entry should follow below format for an entry.

If we are not supposed to be using this option, why is it included in the Adaptation and Bring-Up guide?

hello rgalliath,

it’s an information for PinMux configuration for the bring-up process.
the mandatory (must have) configurations will be like hardcoded, such that mandatory configurations cannot be changed.
for example, this mandatory configurations used specific for IOs in PinMux configurations, such as I2C SCL/SDA pins should be in input enable mode.
thanks