Pinmux of Jetson Nano

Hi… I am a beginner and unfortunately, i bought the Jetson Nano B01 SOM waveshare version. Unfortunately because that I didn’t know would be so difficult just to configure the GPIO pins. I already have installed the OS. I couldn’t find a good explanation regarding it.

How can I edit the GPIO pins? Can someone please help me? It is really frustrating for me.

hello adnan.f.a,

may I know what’s the actual use-case.
you don’t need to alter the pin through pinmux configuration if the pin already a GPIO pin.
please see Pinmux Changes session if your board schematic differs from that for your developer kit carrier board, you must change the pinmux configuration applied by the software.

you may also refer to Topic 144550, for several ways to access GPIOs. such as, kernel APIs, python scripts, C++ samples.

I want to use two motors using my jetson nano that’s it. As i said earlier i am a beginner. Sorry those technical words are really hard for me to understand(the links you provided.) is there any simple explanation on how can i update my pinmux configuration on an existing os?

hello adnan.f.a,

no… I meant you can use those GPIO pins directly.
you may see-also NVIDIA Jetson Nano J41 Header Pinout - JetsonHacks

1 Like

Thanks mate… I tried with the samples provided in the jetson.gpio and i could see that i have 4 0’s in my output (in the pins where i have connected my wires.) but when i run a program for running motors the motors dont run. Can you assume something what might be wrong there?

hello adnan.f.a,

please narrow down the issue,
are you able to toggle the pin? you may probe the pin to check you’re able to see high/low signaling on the oscilloscope.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.