Hi bought PointGrey BFLY PGE 13E4C-CS, I am using TX1 and i have setup manual IP.

I tried to run /flycapture. FlyCapture2Test and GigEGrabEx

FlyCapture2 library version:
Application build date: Apr 5 2016 15:14:49

Number of cameras discovered: 0
Number of cameras enumerated: 0
Done! Press Enter to exit…

I am getting following response any suggestions ?

I tried to run it as root, any suggestions ?

root@tegra-ubuntu:/Drive/flycapture. ./GigEGrabEx
FlyCapture2 library version:
Application build date: Aug 29 2016 08:57:22

Number of cameras discovered: 1

Serial number - 16########
Camera model - Blackfly BFLY-PGE-13E4C
Camera vendor - Point Grey Research
Sensor -
Resolution -
Firmware version -
Firmware build time -
GigE version - 1.2
User defined name -
MAC address - 00:b0:9d:f6:9d:d4
IP address -
Subnet mask -
Default gateway -

Number of cameras enumerated: 0
Done! Press Enter to exit…

root@tegra-ubuntu:/Drive/flycapture. ./FlyCapture2Test
FlyCapture2 library version:
Application build date: Aug 29 2016 08:57:43

Number of cameras detected: 0
Done! Press Enter to exit…

I saw this question also on the Jetson TK1 forum…is this on a TK1 or TX1? Answer from the other forum copied here:

I do not know the particular camera nor the application/SDK, but it sounds like it is networked. Is the camera connected by ethernet to a switch and the switch to the Jetson? Or is the camera going to a router and the router to Jetson? Is USB used at all?

It may be possible to at least verify networking if you know IP addresses, protocol (e.g., TCP, UDP), and port. If network can be verified, then configuration can go on to specifics of the flycapture2 software.

Additional note: Addresses in the subnet are often what get assigned when there is a failure to configure for some reason…sometimes that address space is a default to fall back on. More information on how your network is configured and how devices are physically attached (such as via switch versus via router) would be useful, along with output of “ifconfig” and ping to the camera address (though ping is not definitive since not every device supports ICMP protocol).

I am using a PCIe Ethernet card on TX1 and i manually assigned it IP address

So far as how things are connected together, is the PCIe network card on the JTX1, and the camera connected by ethernet switch to the Jetson? Or by a router? What is the camera’s IP address? To know more about how it should be behaving, it would also be useful to see the output from the commands “ifconfig” and “route”. Any information on what network protocol is used would also be useful, e.g., UDP or TCP. Hopefully the information will help narrow down what is missing.

its okay, i have fixed it :) Will publish a small wiki soon about setting up PtGrey cmaera’s soon

excuse me .Do you link the camera throuth a router or a switch?

Excuse me.I have the same problem with you ,how did you solve it ? thanks.

After some trial and error I am finally able to grab images without any problem consistently. I wanted to share here if someone else drops by this thread.

There is not much out of ordinary. I have used the persisted IP configuration from https://www.ptgrey.com/KB/10933 - a small tip is if you have windows machine, install full/complete version of FlyCapture2 SDK (there are two of those at pointgrey download page as of this writing - take the bigger one). And you will find an utility named GigEConfigurator . This will do the register update. If you are not excited about manually calculation the values - like what happens if we set bit 31 to this value- of course.

I have set static IP for the Jetson as well (for me it was Jetson TX2 - but I think these does not matter.

Then disable the RPF using the commands provided in above KB. I have permanently disabled it - gave me a lot of trouble. Because it works sometimes for some reason. I had to change the command to change eth1->eth0. Check what iface you have.

The eth0 was getting two IPs - one static and it was still asking for DHCP lease. I have disabled the DHCP server to make sure it does not do that.

I have also disabled Network Manager and using /etc/network/interfaces file to configure network. This may not be required though.

Just some additional information…

It is actually ok to get two IP addresses for a single NIC (it’s called “multi-homed”). Often though this is difficult when something like NetworkManager ends up replacing the desired static address instead of adding the second address through DHCP (I believe the technical terminology is that “it’s a pain in the…”).