Problem adding kernel support on XenServer

I’ve encountered a problem while adding kernel support to the latest MLNX_OFED-2.3-1.0.1. I downloaded the latest version (MLNX_OFED_LINUX-2.3-1.0.1-xenserver6.x-i686, checked both: iso and tgz) from the website. Then I executed the following command on the DDK (XenServer-6.2.0-SP1-ddk.iso, CTX139817 - Driver Development Kit - For XenServer 6.2.0 Service Pack 1 - Citrix Knowledge Center http://support.citrix.com/article/CTX139817 ):

./mlnx_add_kernel_support.sh -m /mnt/tmp/MLNX_OFED_LINUX-2.3-1.0.1-xenserver6.x-i686 --make-tgz -t /mnt/tmp/

Note: This program will create MLNX_OFED_LINUX TGZ for rhel5.7 under /tmp directory.

All Mellanox, OEM, OFED, or Distribution IB packages will be removed.

Do you want to continue?[y/N]:y

See log file /tmp/mlnx_ofed_iso.4987.log

Building OFED RPMs. Please wait…

ERROR: Failed executing “MLNX_OFED_SRC-2.3-1.0.0/install.pl -c /mnt/tmp//mlnx_iso.4987/ofed.conf --kernel 2.6.32.43-0.4.1.xs1.8.0.847.170785xen --kernel-sources /lib/modules/2.6.32.43-0.4.1.xs1.8.0.847.170785xen/build/ --builddir /mnt/tmp//mlnx_iso.4987 --disable-kmp --build-only”

ERROR: See /tmp/mlnx_ofed_iso.4987.log

/mnt - is the NFS share. I use tmp directory on this share since local DDK’s tmp doesn’t have enough space.

The logs indicate the following errors:

/bin/rpm -ihv --root /mnt/tmp//mlnx_iso.4987 /mnt/tmp//mlnx_iso.4987/OFED_topdir/RPMS/i686/kernel-ib-devel-2.3-2.6.32.43_0.4.1.xs1.8.0.847.170785xen_OFED.2.3.1.0.0.1.g793fc5d.i686.rpm

error: can’t create transaction lock on /mnt/tmp/mlnx_iso.4987/var/lib/rpm/__db.000

and:

Processing files: iser-1.4.5-2.6.32.43_0.4.1.xs1.8.0.847.170785xen

error: File not found: /var/tmp/OFED/etc/depmod.d/iser.conf

corresponding logs are attached.

The same procedure with older version (MLNX_OFED_LINUX-2.2-1.0.1-xenserver6.x-i686) goes just fine producing the desired output.

So is this a bug or me missing something?

iser-1.4.5.rpmbuild.log.zip (1.76 KB)

mlnx_ofed_iso.4987.log.zip (908 Bytes)

Hello, David

You are correct, I am running as root. There should not be any weird permissions that I can think of. I have “no_root_squash” set in export options of the mount. I did check that I can create/modify files manually from that host. And also the fact that the previous version of OFED build fine indicates that the problem is probably elsewhere.

Thank you for the reply!

I can’t find download link for MLNX_OFED 2.2 for Xenserver. At least xenserver is not listed for 2.2-1.0.1 on mellanox website. Is it available somewhere?

My suggestion for 2.6.32.43-0.4.1.xs1.8.0.855.170800xen is to compile the driver without iser and srp :

./mlnx_add_kernel_support.sh -m /mnt/tmp/OFED --make-iso -t /mnt/tmp --without-srp --without-iser -t (output dir)

Then install the new ISO with mlnxofedinstall script.

Other options are :

1.Revert back to 2.6.32.43-0.4.1.xs1.8.0.847

2.Use MLNX_OFED 2.2

it looks to me like the rpm tool command failed and now the OFED sources are missing so you’re getting a compile error on iser.

I’m pretty sure 2.6.32.43-0.4.1.xs1.8.0.847 was verified and would not need add kernel support script to compile. have you tried it ?

Also, have you tried installing locally instead on nfs tmp ?

Thank you for all the replies!

Just want to give a heads up that the latest MLNX_OFED gets rebuilt without any problems. The versions are:

MLNX_OFED_LINUX-2.4-1.0.0

Linux XenServer-6.2 2.6.32.43-0.4.1.xs1.8.0.855.170800xen #1 SMP Mon Jul 21 05:12:35 EDT 2014 i686 i686 i386 GNU/Linux

XenServer DDK 6.2.0-87218c

Does anyone know when does the version for XenServer 6.5 is expected to be released?

Hello,

sorry for hijacking this thread, but same problem here with MLNX_OFED_LINUX-2.3-2.0.0-xenserver6.x-i686.iso. Current xenserver 6.2.0 with all updates have “Linux 2.6.32.43-0.4.1.xs1.8.0.855.170800xen #1 SMP Mon Jul 21 05:12:35 EDT 2014 i686 i686 i386 GNU/Linux” kernel. I can’t install IB drivers directly from provided iso, as I’m getting error:

The 2.6.32.43-0.4.1.xs1.8.0.855.170800xen kernel is installed, MLNX_OFED does not have drivers available for this kernel. You can run mlnx_add_kernel_support.sh in order to to generate an MLNX_OFED package with drivers for this kernel.

So I tried to build drivers for this kernel using citrix xenserver DDK image, all sources are on local filesystem, I’m trying to build as root, it fails with similar error:

Build ofed-scripts 2.3 RPM Running rpmbuild --rebuild --define '_topdir /mnt/temp//mlnx_iso.6012/OFED_topdir' --define 'dist %{nil}' --target i386 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /mnt/temp/mlnx_iso.6012/MLNX_OFED_SRC-2.3-2.0.0/SRPMS/ofed-scripts-2.3-OFED.2.3.2.0.0.src.rpm Build mlnx-ofa_kernel 2.3 RPM Running rpmbuild --rebuild --define '_topdir /mnt/temp//mlnx_iso.6012/OFED_topdir' --define '_target_cpu i686' --nodeps --define 'configure_options --with-core-mod --with-user_mad-mod --with-user_access-mod --with-addr_trans-mod --with-mthca-mod --with-mlx4-mod --with-mlx5-mod --with-mlx4_en-mod --with-mlx4_vnic-mod --with-cxgb3-mod --with-cxgb4-mod --with-nes-mod --with-ipoib-mod --with-iser-mod --with-e_ipoib-mod --with-srp-mod --with-rds-mod --with-nfsrdma-mod' --define 'KVERSION 2.6.32.43-0.4.1.xs1.8.0.855.170800xen' --define 'K_SRC /lib/modules/2.6.32.43-0.4.1.xs1.8.0.855.170800xen/build/' --define '_prefix /usr' /mnt/temp/mlnx_iso.6012/MLNX_OFED_SRC-2.3-2.0.0/SRPMS/mlnx-ofa_kernel-2.3-OFED.2.3.2.0.0.1.g7e4238c.src.rpm /bin/rpm -ihv --root /mnt/temp//mlnx_iso.6012 /mnt/temp//mlnx_iso.6012/OFED_topdir/RPMS/i686/kernel-ib-devel-2.3-2.6.32.43_0.4.1.xs1.8.0.855.170800xen_OFED.2.3.2.0.0.1.g7e4238c.i686.rpm error: can't create transaction lock on /mnt/temp/mlnx_iso.6012/var/lib/rpm/__db.000 Build iser 1.4.5 RPM Running rpmbuild --rebuild --define '_topdir /mnt/temp//mlnx_iso.6012/OFED_topdir' --define 'src_release 2.6.32.43_0.4.1.xs1.8.0.855.170800xen' --define 'KVERSION 2.6.32.43-0.4.1.xs1.8.0.855.170800xen' --define 'K_SRC /lib/modules/2.6.32.43-0.4.1.xs1.8.0.855.170800xen/build/' --define '_prefix /usr' /mnt/temp/mlnx_iso.6012/MLNX_OFED_SRC-2.3-2.0.0/SRPMS/iser-1.4.5-OFED.2.3.135.g7e4238c.src.rpm Failed to build iser 1.4.5 RPM See /tmp/OFED.6078.logs/iser-1.4.5.rpmbuild.log [root@localhost ~]# tail -n15 /tmp/OFED.6078.logs/iser-1.4.5.rpmbuild.log + /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump + /usr/lib/rpm/brp-python-bytecompile + /usr/lib/rpm/redhat/brp-java-repack-jars Processing files: iser-1.4.5-2.6.32.43_0.4.1.xs1.8.0.855.170800xen error: File not found: /var/tmp/OFED/etc/depmod.d/iser.conf Processing files: iser-debuginfo-1.4.5-2.6.32.43_0.4.1.xs1.8.0.855.170800xen Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/OFED RPM build errors: user builder does not exist - using root group libuuid does not exist - using root user builder does not exist - using root group libuuid does not exist - using root File not found: /var/tmp/OFED/etc/depmod.d/iser.conf

Any advices how to fix it? Thanks!

hmm,

I am assuming you are running as root?

Do you have any weird permissions on /mnt/ that would prevent rpm from executing?

No problem,

it should be there in the Mellanox.com website under Archvies :

http://www.mellanox.com/page/software_overview_ib http://www.mellanox.com/page/software_overview_ib

Please note you will have to compile it with mlnx_add_kernel_support script

Thanks!

got 2.2 compiled without any problems!