Problem in install drivers from GTX GPU 1060 in Linux OS 64 bit

Dear all, nice to meet you. How’s it going ?

When I did install the linux OS in my personal computer, my GPU GTX 1060 stoped be recognized by the computer hardware. Before I used Windows 10.

I tried to install the driver using root, but the following error appeared:

ERROR: An NVIDIA kernel module ‘nvidia-drm’ appears to already be loaded in
your kernel. This may be because it is in use (for example, by an X
server, a CUDA program, or the NVIDIA Persistence Daemon), but this
may also happen if your kernel was configured without support for
module unloading. Please be sure to exit any programs that may be
using the GPU(s) before attempting to upgrade your driver. If no
GPU-based programs are running, you know that your kernel supports
module unloading, and you still receive this message, then an error
may have occured that has corrupted an NVIDIA kernel module’s usage
count, for which the simplest remedy is to reboot your computer.

There is no software using my GPU and I have already restarted the computer.

Can you help me ?

Thanks !

Sounds like there was already a driver installed by the distribution and you tried to use the .run installer. Don’t use the .run installer.
Which distro did you install?

Hi Generix, how’s it going ?

I did not install any driver. I am using ubuntu distribution.

Thank you !

please install the driver using
sudo apt install nvidia-driver-440
or simply using the Software&Updates application. If that doesn’t resolve the issue, please run as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).