Problem installing ARM CUDA cross tools

I’m trying to set up a cross build environment on Linux targeting the ARM platform.

I have followed these steps from the download page:
sudo dpkg -i cuda-repo-cross-sbsa-ubuntu2004-12-4-local_12.4.0-1_all.deb
sudo cp /var/cuda-repo-cross-sbsa-ubuntu2004-12-4-local/cuda-*-keyring.gpg /usr/share/keyrings/
sudo apt-get update
sudo apt-get -y install cuda-cross-sbsa

This completes with NO errors, but there are no cross tool binaries installed. E.g. nvcc is no where to be found.

Installing on Ubuntu 20.04 but also tried 22.04 with the same results.

I also tried the aarch64 .deb with the same results.

How do I get the NVIDIA cross tool binaries to install?

Note I see there is a very similar request that was made back in January, so I guess I won’t hold my breath waiting for an answer.

But hoping for some suggestions on how to resolve the issue.


The instructions for the ARM CUDA cross tools installation implies that nvcc and related binaries would be installed. For example the Post installation configuration has you set up the path to a bin directory that is NOT created during the installation process. I was finally able to find a totally different discussion on another site related to instructing nvcc to use a cross compiler. From that I was able to deduce that in addition to the cross tools package you also must have the x86 flavor of the SDK installed in order to have nvcc and friends. It would be nice if the documentation was clearer on this.

Hopefully this will help others who encounter this same issue, like the user back in January that was asking the same thing but never got an answer.

Refer to the nvcc documentation for the command line options to use. Note that even there I hit an issue the docs show using both of the options but only the one for specifying the cross compiler actually works the one for specifying the architecture failed to build.