Problem re-enabling graphical interface in Orin AGX

So i have a Jetson Orin AGX 32GB developer kit emulated as the NX orin 8GB.
I am working with Deepstream 6.2, and i have a pipeline that uses nvdrmvideosink. In order to run it, i have to stop the graphical interface using sudo systemctl start and run sudo modprobe nvidia-drm modeset=1 and the pipeline does start, however, i am having trouble restarting the graphical interface again after my pipeline is done. Normally on the Xavier AGX, i would run sudo systemctl start and it works but with the Orin, it doesn’t.

A side note: the command sudo systemctl start followed by sudo systemctl start does start the graphical interface again, but running sudo modprobe nvidia-drm modeset=1 and my pipeline in between renders sudo systemctl start useless.

So my question is, how can i restart the graphical interface after running my pipeline?

For disabling Ubunut desktop, we run the commands:
Accelerated GStreamer — Jetson Linux Developer Guide documentation

$ sudo systemctl stop gdm
$ sudo loginctl terminate-seat seat0
$ sudo modprobe nvidia-drm modeset=1

Please try the command and see if desktop is back:

$ sudo systemctl start gdm


I tried that, the command sudo systemctl start gdm doesn’t really get the desktop back up, i am still stuck with a black screen.

@DaneLLL Any updates regarding this issue?

One thing to note is that if i disbale the ubuntu desktop with the commands you mentioned above and i don’t include the line sudo modprobe nvidia-drm modeset=1, using sudo systemctl start gdm actually gets the desktop back up.

So the issue really is with the command sudo modprobe nvidia-drm modeset=1 which unfortunately is needed for the nvdrmvideosink.
I am not 100% sure what it does, but do i have to undo it somehow before starting the gdm service again?

Per modprobe(8): add/remove modules from Kernel - Linux man page

We can remove modprobe with -r option. Please try sudo modprobe -r nvidia-drm and see if it works.

Thanks, removing the modprobe with the -r option worked.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.