Problem runnning the Driveworks samples ./sample_hello_world

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 20.04

when we tried to run any sample code from driveworks 4.0.0 ( originally we had driveworks 5.2 but the bin folder has no samples) , and we get the following error: error while loading shared libraries: cannot open shared object file: no such file or directory.

Another question: to run any sample we need the connection to the host pc all the time? we have tried to install all the packages on the Drive OS (docker, driveworks, tegraRT etc) .

Why are you using DRIVE OS 5.2.6 on Orin? Only DRIVE OS 6.x support Orin.

sorry. yes, we have drive os 6

DriveWorks 4.0 is not compatible with Orin. If this issue remains unresolved, please consider creating a new topic in DRIVE AGX Orin General - NVIDIA Developer Forums, and provide the correct information there.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.