Missing libnv_extimgdev.so library while running sample any samples

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
[Yes] DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[Yes] Linux

Hardware Platform
[Yes] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[Yes] native Ubuntu 18.04


I just installed driveworks 3.5 on the AGX Tegra A and I am trying to verify my installation using the sample hello world application but am getting the following error:

./sample_hello_world: error while loading shared libraries: libnv_extimgdev.so: cannot open shared object file: No such file or directory

I have tried searching for the .so throughout the Tegra A and it is not present. Is there a library I need to install/reinstall to fix this issue? Any help would be highly appreciated.

Dear @SKoyal,
Is it possible to test with latest release( DW 4.0+ DRIVE OS 5.2.6)?

Hello SivaRamaKrishnaNV,

I tried with DW 4.0 with DriveOS 5.2.6 and the sample was running. I just realized that I have supplied wrong information. I have installed DW 3.5 with DriveOS 5.2.6. I wonder if this is the problem. If so can you please let me know how to install DriveOS 5.2.0 from the sdkmanager, as the version of 5.2.0 is not popping up in the selection list. Please note that I have also downgraded the sdkmanager to v1.9.3.x. Please see attached.

Dear @SKoyal,
Could you check lauching sdkmanager --archivedversions to see old releases in the list?

Hello SivaRamaKrishna,

Thank you for the help. I could install the Drive 5.2.0(using the CLI) and driveworks3.5 . I was doing this project to run the sample signet as shown in the documentation here. However I can not find the sample in the bin folder(see picture below).

Or I cant find it in the samples folder(see picture below).

I have tried finding the sample using the find command but could not locate. Could you please help me locate it? Or am I misinterpreting something! Any help would be heavily appreciated.

PS. I have verified the installation by running the sample hello world and I get no errors.


Dear @SKoyal,
The NV DNN modules are not available in DRIVE OS + DW release in devzone. If you want to use NV DNN Modules, please use DRIVE SW 10.0.

1 Like

Hello SivaRamaKrishna,

I was looking into the documentation for using DRIVE SW 10.0 here. I am trying to migrate from Drive OS 5.2.0 to Drive SW 10.0. The table below suggests I contact an Nvidia representative. Could you please mention the specifics of this migration?

Thank you again for your help.


Dear @SKoyal,
I think DRIVE OS 5.2.0 to DRIVE SW 10.0 should work and you may to downgrade/reflash aurix manually later. Could you give a try using sdkmanager. Before flashing please uninstall DRIVE OS 5.2.0 on host using sdkmanager and then check flashing DRIVE SW 10.0 and update us the status.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.