Problem with displayport connection from 690 GTX to LG 34UM95

I’m running Fedora 20 with a 690 GTX and a brand new LG 34UM95 and I’m having some problem getting the displayport connection to work. If I boot connected to the displayport, the login screen comes up correctly and after I log in, the screen stays up for a few seconds while everything is loading and then I lose the signal from the graphics card and the screen goes into power saving mode. After some poking around, I discovered that the graphics card was switching from the displayport to the DVI-D port for some reason. If I connect the DVI-D port to the HDMI port on the monitor, I get a proper screen image except the fonts seem to be screwed up. There are some warning messages in the xorg log about the EDID contradicting itself but I don’t know if they are relevant to this problem.

If I boot from the DVI-D port to the monitor’s HDMI port, everything works great except I can only rum at 50 Hz. I’ve also tried hooking up the monitor to my Windows box with a 680 GTX via displayport and it comes up fine. So it appears the displayport on the monitor is working correctly. I’ve also tried two different displayport cables and also tried the 340.17 beta drivers with the same result.

Maybe it’s just a configuration issue but I don’t know. Thanks for any help.

nvidia-bug-report-lg-displayport.log.gz (366 KB)

Did you plug the HDMI monitor in before you generated this log file? There are two display configuration events in the log. The first is when the X server is starting. It detects the LG 34UM95 as the only connected monitor and configures the screen to use that:

About 20 seconds later, some X client requests that the driver turn that monitor off:

The so-called “NULL” MetaMode is one with no active display devices. So that explains why your monitor is turning off a few seconds after the server starts. You’ll need to determine which program is responsible for requesting that the monitor be turned off and configure it differently. Does the same problem occur if you use a different desktop environment, or if you start a bare X server from the console?

As for the HDMI monitor, it’s possible that whatever’s responsible for the NULL modeset request is also responding to an HDMI hotplug event by doing another modeset to turn that monitor on.

OK, I’ve got the displayport working again although it’s still not clear to me what was causing the problem in the first place.

I normally use KDE, so I tried logging in using Gnome and that worked fine. I then tried logging in using the KDE Failsafe mode, and that failed. The only thing I have set up to run automatically when KDE starts is “nvidia-settings --load-config-only”. I tried getting rid of that and it still failed. At this point I had no clue what it could be so I decided to try the nuclear option by getting rid of my .kde config directory. THAT worked. I had to reconfigure KDE, but that was much easier than trying to figure out what program was messing me up.

Thanks for the help.

Update. It stopped working again. It seemed to be triggered by me disabling displayport 1.2 support on the monitor. The monitor was having problems going into power saving mode so I thought I would disable DP 1.2 to see if it made any difference. Right after that it quit working.

I decided to rename my .kde directory again to start over and it came back to life by itself. So I looked around in the old and new .kde directories and found what I think was the problem. I found a config file in the kscreen directory. The non-working version looks like it had the screen disabled. The working version has the screen enabled.

I googled around a bit and found that the kscreen service could be easily disabled, which is what I did. I then tried enabling and disabling DP 1.2 support on the monitor and rebooted each time and it came up working both times. So it looks like the problem is solved. Whatever kscreen is doing in the background, it’s doing it wrong.

Now the only problem I have left is the screen won’t go into power saving mode. The fun never ends.

I too have the not going into power saving mode on displayport issue with the 34UM95 and have a similar setup.

  • Fedora 20
  • Gnome 3.10
  • akmod supplied NVIDIA driver 331.89
  • GeForce GT 640
  • displayport 1.2 is off

Sorry I don’t have anything to add, just hoping to get more eyes on this in hopes of finding a fix.

Am willing to provide more info if needed.

I have another but somewhat related issue (with Geforce GTX 680). When switching between X and tty, the monitor enters power saving mode (but then switches after all). Because of that switching takes ridiculous 5-6 seconds (the monitor is set to use DisplayPort 1.2 and the cable is VESA certified for it).

A lot of DP problems are happening because of the poor cables or otherwise bad hardware which doesn’t follow the VESA specification about the power pin in the cable. But in my case I’m not sure what the issue is.

I’ve gone back to using the HDMI connection on the monitor because I never could figure out why the display port wouldn’t work with power saving mode.

I searched around a bit but couldn’t find any helpful information. I’m not sure if this is a problem with the nvidia drivers, X or something else.

I’d like to know if someone actually has a display port connected monitor that successfully goes into power saving mode. Maybe someone here can post a reply if they have a working configuration.

It works for me (with some quirks). Is your DP cable VESA compliant? There is a surprising amount of junk on the market which doesn’t adhere to the standard and causes all kind of bugs (they are related to the power pin usually). See my previous post in this thread.

That bug can affect not only the cable, but some monitors as well. I’m using Dell U2413 in DisplayPort 1.2 mode and Accel UltraAV DisplayPort 1.2 cable.

I’ve tried two different DP cables. One that came with the monitor and another one I bought separately. They should be VESA compliant but I don’t know how to tell for sure.

I have a windows computer. Maybe I’ll hook the monitor up to it and see if it goes into power saving mode there. If it does, that might suggest the problem is on the linux side and not with the monitor or DP cable.

I’ve tried two different cables. They both have the same issue on Linux. I’m dual booting Win 8.1 and it goes into power saving mode just fine. This is almost certainly a driver/software issue.

We don’t have LG 34UM95 monitor. I have tested with DELL U2913WM but unable to reproduce. Is it possible to reproduce this issue by using EDID of 34UM95 on other monitors? If yes please share EDID of 34UM95 ?

I don’t know how to use the edid with another monitor, but if you provide instructions I will do it.

In the mean time, here is the edid of the LG 34UM95 in ascii:

00 ff ff ff ff ff ff 00 1e 6d d8 76 01 01 01 01 32 17 01 04 b5 50 22 78 9e ca 95 a6 55 4e a1 26 0f 50 54 21 08 00 71 40 81 80 81 c0 a9 c0 b3 00 d1 c0 81 00 01 01 e7 7c 70 a0 d0 a0 29 50 30 20 3a 00 20 4f 31 00 00 1a 9d 67 70 a0 d0 a0 22 50 30 20 3a 00 20 4f 31 00 00 1a 00 00 00 fd 00 38 3d 1e 5a 20 00 0a 20 20 20 20 20 20 00 00 00 fc 00 33 34 55 4d 39 35 0a 20 20 20 20 20 20 01 44 02 03 11 71 23 09 06 07 44 10 04 03 01 83 01 00 00 9f 3d 70 a0 d0 a0 15 50 30 20 3a 00 20 4f 31 00 00 1a 7e 48 00 e0 a0 38 1f 40 40 40 3a 00 20 4f 31 00 00 18 01 1d 00 72 51 d0 1e 20 6e 28 55 00 20 4f 31 00 00 1e 8c 0a d0 8a 20 e0 2d 10 10 3e 96 00 20 4f 31 00 00 18 02 3a 80 18 71 38 2d 40 58 2c 45 00 20 4f 31 00 00 1e 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 3a