Problem with NVIDIA-Linux-x86_64-430.34.run - Solved

Hello there,

I’m not a developer, but it looks like there was no other place to ask a question. I just wanted to mention that the Geforce RTX2060 drivers bundle for Linux 64 (NVIDIA-Linux-x86_64-430.34.run) gives a checksum error when trying to execute it.
To be precise, the error message reads : “Verifying archive integrity… Error in check sums 2556917429 1109394152”
I’ve tried downloading the file 2 more times, with the same result.
I see that the file is fairly recent (9th of July), so maybe I’m the first experiencing the issue.

Thanks for your help, and sorry if this wasn’t the right channel for me to ask.

Kind regards.

It’s the correct place, don’t get irritated by the “devtalk” title.
Where did you dowlnoad it from? I had no problems using a version from here:
https://http.download.nvidia.com/XFree86/Linux-x86_64/

Hi. Thanks for your quick response.

I downloaded it from the French NVIDIA website (https://www.nvidia.fr/Download/driverResults.aspx/148724/fr)
So I downloaded it with your link this time, and I could open it with no checksum error. This time I also downloaded it directly on the Linux computer, while I previously transferred the file with a USB stick after downloading it from a Windows computer, although I wouldn’t think this could make a difference… Or so I thought until I tried to download directly with my initial link… and I worked. I’m puzzled. I could have disconnected the stick at a wrong time once… but 3 times?
So sorry for wasting your time, and thanks a lot. This thread can be closed and even removed, as it was a false alert.

Now I’m stumbling on the next hurdle, i.e. I get a “The distribution-provided pre-install script failed! Are you sure you want to continue?” So I aborted the install. I guess I should be able to find help on that somewhere on the web and hopefully won’t have to ask here again. I’m totally new to Linux/Ubuntu and I’m only rushing with this graphic card drivers install because by default the system doesn’t recognise the RTX2060 at all (it reads “llvmpipe (llvm 8.0, 256 bits”), and it displays nothing at all in the “Addtional drivers” section. As is, the display is just very poor and impossible to adjust.
Anyway, again I’m new to Linux, and this second issue is most certainly my mistake as well.

Thanks again, and have a nice week-end.

That error message is a safety measure, don’t use the .run installer.
Just open the Software&Drivers application on Ubuntu and choose to install the nvidia driver. If you want the latest driver, add the ppa: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
Note: Ubuntu will in future provide the latest driver through the standard repos so the ppa will not be necessary anymore.

Thanks again, but I already tried that before trying to download the .run drivers package.
As I mentioned in my previous entry, unfortunately the “Addional drivers” tab in my “Software&Drivers” application is desperately and completely empty. “No addtional driver available”.
Note : I verified that the “Copyright restricted software…” box is checked in the first tab, and I checked it during the Ubuntu installing procedure.
It’s a brand new computer, but I don’t think there’s anything wrong with the graphic card, since I briefly installed Win 10 on it before restarting from scratch with Ubuntu, and it seemed to work fine then (I didn’t try to add drivers there, since it was automatically recognized by Windows). I may have to restart again and setup a hybrid Linux/Windows configuration so I can switch systems, just to be sure.
Or is there something that could prevent Ubuntu from displaying the driver in the “Software&Drivers” application ?

Stock Ubuntu is currently only including older drivers, might be that your gpu requires more current drivers.
Use the ppa to add those, afterwards the newer drivers should appear in the Software application, if not, run
sudo apt install nvidia-driver-430

Thanks again for that next tip. I’ll give it a shot tomorrow, as it gets quite late here.

So many posts while you could simply redownload the file.

./NVIDIA-Linux-x86_64-430.34.run --check
check sums and md5 sums are ok

$ sha256sum NVIDIA-Linux-x86_64-430.34.run 
2b0d584025affb8cffb7440087dd038ebd5a9d2e0d88bbbf7a6b451a5f117d30  NVIDIA-Linux-x86_64-430.34.run

Hi Birdie,

As I mentioned, I didn’t just try it once, but 3 times. I thought it could be a real error, since the file was very recent, otherwise I wouldn’t have asked. I apologized and also confirmed that my initial link was actually OK. Only the 3 first posts were about the checksum error.

I also said that the thread could be closed after the first answer, and that I would try to find my way out of the next issue. Generix was so kind to help me further, and this is why this thread isn’t closed yet.

I just saw that I could still update the title, so I did, in order not to let anybody think that there would really be an issue with the .run file.

If an admin is around, feel free to suppress the whole thread.

Regards

To Generix :
Adding “ppa:graphics-drivers/ppa” to the “Other software” list made the Nvidia drivers show up in the “Addional drivers” tab. I selected the 430 metapackage and… Voilà! the RTX2060 is displayed in the Ubuntu system info, and the resolution automatically adjusted correctly to the screen I’m using.
Thanks so much for your help!