In the DT for sensors, one can declare a pwdn-gpios GPIO. I thought that pwdn stands for PoWerDowN, i.e. when I set the GPIO to 1, the sensor is powered down, shut down, not powered anymore. But when I look at the *_power_on() methods in the sensor drivers in kernel/nvidia, I see that they terminate after a call to
gpio_set_value(pw->pwdn_gpio, 1);, which sets the GPIO to 1 and thus should power down the sensor.
Is that gpio misnamed or does pwdn not mean ‘power down’ or are the pwdn pins on all supported boards actually in ACTIVE_LOW logic ? If pwdn is actually in ACTIVE_LOW logic, maybe we could simply name it ‘pwup’, for PoWerUP, and admit that it is a ACTIVE_HIGH signal.