Problem with USB3


I’m experiencing a strange issue with a jetson nano module, maybe someone here can help me out.

I’m running a kernel compiled from source with the tegra default config
I’ve downloaded the kernel from git using the source_sync script and the version is 4.9.337

Unfortunately I cant seem to get the USB3 to work on the module.

I’ve verified that both:
as well as
are present in the rootfs

When the system boots up i receive this error in dmesg.

[    6.462882] tegra-xusb 70090000.xusb: Direct firmware load for tegra21x_xusb_firmware failed with error -2
[    6.462885] tegra-xusb 70090000.xusb: Falling back to user helper
[    6.463435] tegra-xusb 70090000.xusb: cannot find firmware....retry after 1 second
[    7.486852] tegra-xusb 70090000.xusb: Leaving it upto user to load firmware!

and i don’t get the

[    7.566083] tegra-xusb 70090000.xusb: Firmware timestamp: 2019-10-17 15:58:59 UTC, Version: 50.25 release

running lsusb doesn’t show anything

The module is a jetson nano emmc

I’ve attached the full dmesg log in the hope this can help.

dmesg.log (66.0 KB)

can anyone help me out in diagnosing the issue?

thanks very much for your support.

The xusb firmware is read from the initrd but not rootfs.

thanks for your reply, you mean that i have to add the xusb firmware into the initrd?

I thought it was already there, i’m going to check this

can you also point me in the right direction on where exatly to get the xusb firmware module file other then the rootfs? is it in any specific nvidia package? thanks

There is initrd binary on your host PC where you flash the device. Should be located Linux_for_Tegra/bootloader.

Go to search how to convert that initrd back to small rootfs and then check that rootfs content.

Please be aware that I am not talking about Linux_for_Tegra/rootfs.

Please also check if you ever tried to install other kind thing like initramfs and that overwrite the old initrd and also the usb firmware…

Indeed for my needs i had to create my own custom initramfs and i forgot to add the firmware for the USB.

added them, repacked, and now it works fine. thank you

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.