Problems with nVidia legacy drivers on Crunchbang

The video card in question is GeForce 6600GT. As a distro I’m using CrunchBang Linux, kernel: 3.12-1-686-pae SMP Debian 3.12.9-1 (2014-02-01) i686

At first I tried the recommended proprietary driver (.run) which is 304.121, and I successfully installed the drivers using this wonderful guide: http://crunchbang.org/forums/viewtopic.php?id=19398. As I saw it had problems I decided to try other driver versions (see below). Then I tried to install the distro’s driver using this guide on the Debian wiki. Everything works as expected after starting the X session, aside from a few quirks:

  • higher RAM usage, after a fresh install #! would take about 70-90MB RAM on a fresh boot, but now it takes about 340MB RAM with the driver. I find this rather weird, I mean I know that more hardware acceleration means more RAM usage… but not a whopping 250MB RAM
  • Firefox, Thunar, and a few other programs are very sluggish. In Firefox when loading pages or scrolling on the page and CPU usage spikes to 100% quite a few times. Even now as I’m typing this the CPU stays around 20%
  • lots of tearing
  • not using my monitor’s native resolution

But regardless of all this everything else works fine, for example moving windows around or resizing them doesn’t cause any tearing or sluggishness, and doesn’t take a lot of CPU, also I can play HD h.264 videos! You might wonder if I’m insane or why do I get so excited over this, but I wouldn’t be able to do that under Windowze without opting in for a slideshow! And not to mention it barely gets over 60% CPU! W00T.

So then I decided to try the older drivers to see if any of the fix anything, so this is what proprietary I tried so far:

304.121, 304.119, 304.117: All work but with the aforementioned problems.
304.116: Returns X11 errors when I try to start slim (#!'s GDM). Xorg.log
304.88, 304.84, 173.14.37: refuses to build, nvidia-installer.log.
304.64-304.51: reports it can’t find the headers under ‘/lib/modules/3.12-1-686-pae/build/include/linux/version.h’. What I find weird about this is the fact that the other drivers compiled/were built without complaining about this… I haven’t tried any earlier versions than this as I thought that they would probably give the same errors
173.14.39, 173.14.38: Installs fine, but it borks my X session, after starting slim, the PC freezes, I can’t switch back to the TTY, can only restart. 173.14.38 Xorg.log
325.15: Prompted me to get the legacy drivers (which I did) and told me that my GPU will be ignored by this driver
Bug report: http://s000.tinyupload.com/index.php?file_id=63990485262245931524
Any suggestions?

bump

I noticed that most of all GTK+ applications have this problem, and I would add LibreOffice to the list as I’ve tried it now, and it very slowly draws all the icons every time I resize the window or I save a document. It’s seriously sluggish.

What desktop environment you are running - like gnome, kde etc ? Is issue repro with any other desktop environment ? Is the issue repro if you disable desktop effects OR composite ?

Thanks for your reply.
I’m running OpenBox, which is the default desktop environment for #!
I haven’t tried any other environment, but I’ll try gnome in about an hour and report (edit this post).
By repro I assume you mean reproducible.
I’ve previously disabled compositing, but that didn’t change anything (except the lack of effects). Also I ran X.org with verbosity for the log above, and that from what I noticed disabled all the effects and the wallpaper, and even then GTK applications were very slow.
I also noticed that in LibreOffice, it takes it ages to load the icons (ie. on the toolbars). Every time I save a document, or I move to certain areas of the document (that trigger some additional toolbars) it slows down tremendously, again (I think) because of the icons.

You can try to change gtk2-design to mist. For me this helped when I used older drivers (OpenSuse, KDE).
Greetings,
DJ

@DJ: Thanks for the suggestion but how can I do that?

Okay, I tried those so far:
xfce4: Works fine, Firefox is still sluggish, so are most of the GTK apps, but it seems LibreOffice works properly, no slow icons or such
gnome3: same as above
kde: very slow loading (probably due to slow HDD) but no different than the above two.

It seems, there is something wrong with older NVidia-drivers. It’s always the same: firefox is slow and often the screen is locked, especially on this site (devtalk). The locking becomes less, when you forbid background graphics.
I tried a lot, but in vain. Even accelerated nouveau is blocking the screen. With shadowfb=true (the opposite of the default value) locking vanishes but output is slow.
After I changed all cards to ATI with radeon driver (with radeon.agpmode=-1, pci), old laptops (Dell M60) are usable again.
More I don’t know.
Greetings,
DJ

By gtk2-theme and “mist” you mean to change the widget theme? I tried to set it to the distro’s default (no mist here) and it doesn’t change anything unfortunately.

Yes, but adwaita should work, too. Some work, some don’t. But I removed all old NVidia cards and therefore cannot test it now. With new NVidia cards and new drivers there is no problem at all.
I don’t know, how you can change the theme. In OpenSuse with KDE it’s quite simple. Perhaps you have to install more themes.
Greetings,
DJ

Thanks! That solved the problem with some GTK apps, and with LibreOffice, but Firefox is still slow so far, as expected.

You’re welcome. There are no conflicts with Google browser or opera, I think.
Greetings,
DJ

Unfortunately I don’t trust Chrome/Chromium anymore to use it, otherwise I would move to those browsers, but if I won’t get any solutions aytime soon I’m afraid I might have to.
What I noticed is that Firefox is the slowest when trying to scroll up a page (sometimes when scrolling down it can be really smooth) also when loading pages with a lot of images, scrolling on those pages is slow as well.

Yes, I don’t trust them, too.
Firefox works better on some sites, when you disable scaling. With ctrl-0 the content of sites is not scaled. The disadvantage: you may need glasses.
Greetings,
DJ

Thanks but unfortunately I haven’t seen any improvements, and on some sites it’s also very slow, though fortunately the text hasn’t been sized down on the sites I’ve tried :P
I think I’ll try to compile my own kernel to see if it fixes any problems I’m having at the moment, seems the nvidia devs aren’t that much reliable with helping.

I compiled my own kernel and so far nothing has improved. Help…

Try recompiling cairo with this patch. I have vague recollections that nvdia used to have issues with hardware accelerated gradients and forcing a software fallback for them (that’s what the patch does) would make things better. No guarantees this is the problem you’re experiencing, but it can’t hurt to try the patch.

Thanks for the wonderful suggestion, but I’m not using cairo :)

Of course you are. What do you think draws your GTK themes? Also, what do you think draws all the web content in Firefox? The answer in both cases is cairo.

Ah, I thought you were talking about the desktop widgets.
Which packages should I remove after compiling?

bump Anyone?