Purple stripes on the video and reboot


We are running our GStreamer based application on Jetson Nano.

System information:

$ cat /etc/lsb-release

$ cat /etc/nv_tegra_release
# R32 (release), REVISION: 7.2, GCID: 30192233, BOARD: t210ref, EABI: aarch64, DATE: Wed Apr 20 21:34:48 UTC 2022

When we used an IM219 connected to jetson with csi->hdmi->camera a reboot appear quickly. But when we don’t used camera we don’t have reboot.

Here are the camera images we get on the robots having this reboot problem.


Is it hard to tell what could be the cause of the issue with the provided information. First thing I recommend is to check the log of the kernel ring buffer. Make sure to enable the debug log of your drivers, take a look at this information on how to do that. Can you please provide the output of the command below when the issue appears?:


If it gets too difficult to get the kernel log (due to the issue behavior of appearing too quickly after reboot) perhaps you could try to extract the same log by connecting to the serial console. If you are using a devkit this guide can help with that setup.

Also have you tried loading the module manually yourself after reboot to check if the issue happens as well?

Jafet Chaves,
Embedded SW Engineer at RidgeRun
Contact us: support@ridgerun.com
Developers wiki: https://developer.ridgerun.com/
Website: www.ridgerun.com

1 Like

Enable the debug print in csi2_fops.c to check the error status.


This is a screen of error few millisecond before the crash of jetson nano.

What’s the gsttreamer command?

nvarguscamerasrc ispdigitalgainrange=“4.00 4.00” gainrange=“4.00 4.00” exposuretimerange=“660000 660000” aelock=true ! video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, format=(string)NV12, framerate=(fraction)20/1 ! nvvidconv flip-method=0 ! video/x-raw, width=(int)1920, height=(int)1080, format=(string)BGRx ! videoconvert ! video/x-raw, format=(string)BGR ! appsink

Did you check xvimage sink?

gst-launch-1.0 nvarguscamerasrc ! "video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080,format=(string)NV12, framerate=(fraction)20/1" ! nvvidconv ! xvimagesink sync=false

Hello, unfortunately I can’t use this xvimage sink because we use the camera with a python script here. We don’t have screen connected to the jetson in the robots. Moreover, some robots in our fleet with identical hardware do not have this reboot problem as soon as the camera is used for a few seconds.

serveurCamLive.py (3.4 KB)

OK, could you try MMAPI sample code to get the jpeg to check.


Hello, sorry for the delay. This is the result :

/usr/src/jetson_multimedia_api/samples/09_camera_jpeg_capture$ sudo ./camera_jpeg_capture

[ERROR] (NvEglRenderer.cpp:98) <renderer0> Error in opening display
[ERROR] (NvEglRenderer.cpp:154) <renderer0> Got ERROR closing display

But for me it’s normal because we don’t have display connected to the jetson nano. It’s inside a robot without screen.

You need export DISPLAY=:0 command than run argus_camera_jpeg

This is the result :

/usr/src/jetson_multimedia_api/samples/09_camera_jpeg_capture$ export DISPLAY=:0

/usr/src/jetson_multimedia_api/samples/09_camera_jpeg_capture$ ./camera_jpeg_capture 

[INFO] (NvEglRenderer.cpp:110) <renderer0> Setting Screen width 640 height 480
PRODUCER: Creating output stream
PRODUCER: Launching consumer thread
CONSUMER: Waiting until producer is connected...
CONSUMER: Waiting until producer is connected...
PRODUCER: Available Sensor modes :
PRODUCER: [0] W=3264 H=2464
PRODUCER: [1] W=3264 H=1848
PRODUCER: [2] W=1920 H=1080
PRODUCER: [3] W=1640 H=1232
PRODUCER: [4] W=1280 H=720
PRODUCER: [5] W=1280 H=720
PRODUCER: Requested FPS out of range. Fall back to 30
PRODUCER: Starting repeat capture requests.
CONSUMER: Producer has connected; continuing.
CONSUMER: Producer has connected; continuing.

After run this APP should capture many output*.jpg
Did you check those jpeg file?
If no didn’t have the jpg file you may need copy the APP to ~/ due to permission problem to write file to /usr/src/jetson_multimedia_api/*

Yes jpeg file is ok. We can see a correct pictures without purple stripes.

pictures.zip (2.2 MB)

OK, Please confirm below command have the purple stripes.

gst-launch-1.0 nvarguscamerasrc ! "video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080,format=(string)NV12" ! nvvidconv ! xvimagesink sync=false

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.