pycuda._driver.Error: cuInit failed: unknown error

I’m trying to follow Jupyter-notbook yolo_v4.ipynb tutorial. I got the error described in the image that is attached here. I don’t know how to solve it. please help!!!

the specs are:
• Hardware RX 3070 GPU
• Network Type Yolo_v4
• TAO Version 3.21.11

Refer to Train with my own tlt model #2 - #17 by tmid0819
and No CUDA-capable device is detected on tao detectnet_v2 dataset convert - #4 by NilsAI


Thanks for fast reply. I tried to erase the “tao” from the command line, didn’t work. the second suggestion, to add --privileged, I don’t run “docker run” command, just using the jupyter notebook as it is. How can I add --privileged to the notebook?

I run a docker with --privileged and I ran a dataset_convert command inside the container. this is what I got.

Thanks a lot

May I know the result of below
$ nvidia-smi

See TAO container fails on Google Vertex AI - #58 by mattcarp88, that topic has similar error.
For that topic, need to update nvidia-driver.

The results of nvidia-smi command:

What version of the driver should I install?

Thanks a lot for your assist!

Can you add “--runtime=nvidia” when you run docker run?

More, may I know if you can reproduce the error with below steps?

$ python
>>> from modulus.export._tensorrt import ONNXEngineBuilder

Well, it looks like the problem is that I run Ubuntu 20.04. Now that I switched to Ubuntu 18.04 everything is ok.

Thanks for the info. Currently only Ubuntu 18.04 is full verified.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.