Pycuda libcurand Import Error

I had to downgrade my CUDA installation from 9.2 to 9.0 and I am now getting the following error at “import pycuda.driver”:

ImportError: libcurand.so.9.2: cannot open shared object file: No such file or directory

And at “import tensorrt” I get

ImportError: Please make sure you have pycuda installed

I do have libcurand.so.9.0. What can I do to get pycuda working with CUDA 9.0?

I tried to uninstall pycuda and install it again as per TensorRT installation page, but that did not work. Pycuda was installed via “pip install ‘pycuda>=2017.1.1’”

OS: Ubuntu 16.04

your pycuda import is looking for CUDA 9.2, not 9.0

Yes, I can see that. But pycuda is compatible with CUDA 9.0, isn’t it? My question is, how can I make pycuda look for CUDA 9.0?

install a version of pycuda that has been compiled for CUDA 9.0

or build it yourself:

  1. make sure you have a proper CUDA 9.0 install
  2. follow the pycuda install/build instructions:

https://wiki.tiker.net/PyCuda/Installation/Linux

  1. In step 3, where it says:

$ python configure.py --cuda-root=/where/ever/you/installed/cuda

make sure you modify /where/ever/you/installed/cuda to point to your CUDA 9.0 install

Thank you! Installing the same version from source worked perfectly.