Quadro NVS 420 quad display glitchy under both xinerama and base-mosaic

I’m trying to get four displays (in a grid layout) going on Ubuntu 12.04 attached to a Quadro NVS 420 card. I’ve tried two configurations.

The first configuration uses Xinerama with four screens. It’s okay, but the mouse pointer glitches out occasionally and skips. Because it uses Xinerama, Unity also ends up being ugly and glitchy.

The second configuration uses base-mosaic mode. This setup is much better than the first in terms of looks and functionality, and is less glitchy with the mouse pointer and with Unity. However, it is unusably laggy. I’ve tried tweaking just about every xorg config option I could find, including the iommu=pt kernel option to no avail.

I’ve tried the 302, 304 and 310 drivers but all of them seem to have the same issues.

Any suggestions for how to get this to work? xorg.conf for base-mosaic mode attached. I think it’s the option I’d prefer to get working, if possible.

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    Option         "RenderAccel" "true"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "nvidiaXineramaInfo" "False"
    Option         "BaseMosaic" "True"
    Option         "SLI" "Mosaic"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+1200, DFP-1: nvidia-auto-select +1920+1200, DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1920+0"
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "Composite" "Enable"