Trouble with BaseMosaic on dual GTX 1050s with 3 displays in Ubuntu 16.04

Hi folks,

I’ve spent more hours than I have fingers trying to get BaseMosaic into effect on my machine. The interwebs seem to tell me that my setup should support 3 displays, but 20+ different xorg.conf files later I still can’t get past (nor understand) this error in the X log:

[    12.138] (EE) NVIDIA(GPU-0): Failed to find a valid Base Mosaic configuration.
[    12.138] (EE) NVIDIA(GPU-0): Invalid Base Mosaic configuration 1 of 1:
[    12.138] (EE) NVIDIA(GPU-0): GPUs:
[    12.138] (EE) NVIDIA(GPU-0):     1) NVIDIA GPU at PCI:1:0:0
[    12.138] (EE) NVIDIA(GPU-0):     2) NVIDIA GPU at PCI:2:0:0
[    12.138] (EE) NVIDIA(GPU-0): Errors:
[    12.138] (EE) NVIDIA(GPU-0):     - The video link was not detected
[    12.138] (WW) NVIDIA(GPU-0): Failed to find a valid Base Mosaic configuration for the
[    12.138] (WW) NVIDIA(GPU-0):     NVIDIA graphics device PCI:1:0:0. Please see Chapter 28:
[    12.138] (WW) NVIDIA(GPU-0):     Configuring SLI and Multi-GPU FrameRendering in the README
[    12.138] (WW) NVIDIA(GPU-0):     for troubleshooting suggestions.

Bug report attached. Note that the xorg.conf used in this report lists out MetaModes, I’ve also tried the very minimal xorg.conf suggested in that looks like so:

Section "Device"
    Identifier     "Nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"
    Option         "AllowEmptyInitialConfiguration"
    Option         "BaseMosaic" "true"

unfortunately this minimal xorg.conf also produces the same X log error as above.


nvidia-bug-report.log.gz (116 KB)

Check if adding

Option "SLI" "false"

to the device section helps.

Unfortunately it didn’t help. I also updated to 390.48, see attached bug report.

After the above attempt I also tried adding these flags to the Device section:

Option         "SLIMosaic" "false"
Option         "MultiGPU" "Off"

but those also did not remove/change the “video link was not detected” error.

FWIW I’ve gone through the exercise of setting up two different X Screens, first Screen spanning two displays and the second Screen on the third display. This works in that I can get all three displays to produce output and the mouse can be moved across all three. But the goal is get BaseMosaic to provide a single X Screen. I verified the two-X-Screen config when GPU-0 (GPU-ac8b80b0-dd34-5ee8-a072-0ef11c59ccc4) drove two displays and GPU-1 (GPU-a378b606-85da-f9a9-4fa2-090da1442e1f) drove the third, and vice versa, so the hardware itself seems fine to me.
nvidia-bug-report.log.gz (115 KB)

Hardware is fine, plain driver bug. Or nvidia nerfed basemosaic on geforce so it wouldn’t work at all.

Well, bummer. Does this thread count as a bug report, or do I need to reformat and post elsewhere?

It’s the closest to a bug report you can get, devs are reading here and sometimes respond.
Meanwhile, you could try with earlier driver versions, 384 and 375 would be a good starting point.

Same failure mode with 375.82 and 384.111. I can upload bug report logs from each attempt if needed.

Thanks for your help!

You could try to use kernel parameters

video=vesafb:off vga=normal

to get rid of the vga warning message in dmesg.

That did indeed get rid of the vga warning message in dmesg. Still no dice on the basemosaic error.