Rage 2 crashes when entering the map - seems nvidia specific problem

Hi,

if you want to use the map in Rage 2 with wine it crashes and freezes.

Some folks write you should set DisableAsyncCompute = 1 in games settings.ini, but that does not do the trick.

The game crashes as soon one trys to enter the menu/map/tab.

This problem seems to be nvidia specific, as everyone using other vendors hardware seems not affected by this.

Driver versions i tested with same results: 450.56.02, 450.102.04, 455.50.07

My driver version is Linux Vulkan Beta 455.50.07 on Arch Linux and the game is Vulkan only.

This happens with kernel 5.10.17 and 5.11 as far as i tested.

Hangs for me as well. Five minutes into game and hangs. GTX 1050 Mobile 4GB, prime render offload, NV 460.39 driver. AMD RADV users doesnÔÇÖt get any hang with this game. Game is currently free on Epic Games Store until Thursday so NV QA people can grab and try it.

You can either use Lutris to install EGS and game or use Heroic Games Launcher (third party Linux native EGS client)

Issue persists with different Wine versions as well and AMD RADV users do not have any issues regardless across Wine versions. Also do note, Windows NV users do not have a problem with the game as well. So Linux driver is the culprit here.

System info (prime render offload is being used= __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia __VK_LAYER_NV_optimus=NVIDIA_only):

inxi -SMGxx

System:
Host: asus-FX553VD Kernel: 5.10.13-xanmod1 x86_64 bits: 64 compiler: N/A
Desktop: Cinnamon 4.8.6 wm: muffin dm: GDM3, LightDM
Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
Machine:
Type: Laptop System: ASUSTeK product: GL553VD v: 1.0
serial: <superuser/root required>
Mobo: ASUSTeK model: GL553VD v: 1.0 serial: <superuser/root required>
UEFI: American Megatrends v: GL553VD.308 date: 04/29/2019
Graphics:
Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:591b
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK
driver: nvidia v: 460.39 bus ID: 01:00.0 chip ID: 10de:1c8d
Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia
unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2)
v: 4.6 Mesa 20.3.4 - kisak-mesa PPA direct render: Yes

We have filed a bug internally 3267900 for tracking purpose and working on it actively.
Will keep everyone updated.

1 Like