Ram Boot Of the Jetson TK1

Hello Everyone

I am using Jetson-TK1 board and learn how to use it for our future production,I tried ram boot according to the following wiki:


I have met problems with that guide,I can’t see any log from terminal.
I have done the steps according to that website except u-boot source download,I use the L4T R21.4 uboot source code.

Anyone known the reason? please give some advice.I use the R21.4 uboot source code because I can not git the specify source code according to the wiki,if the problem is caused by u-boot source code,who can download it,and send it to my mail. jackwave@126.com. Thanks very much!

When you execute the following command line about tegrarcm, please pay attention to --loadaddr parameter. That should match the u-boot compile option.
By NV release u-boot, that value should be 0x883d8000.
You can check the definition of CONFIG_SPL_TEXT_BASE @ include/configs/tegra124-common.h in u-boot package.


Thanks for your reply, I have tried your advice, but it does not work.

Also, I have get the u-boot source that specified by the website, with this u-boot, everything is OK, ram boot successfully. So, I think u-boot in R21.4 does support download through USB by itself.

u-boot version in R21.4: 2014.10
u-boot version specyfied by the website:2016.01

Please confirm that u-boot is correctly compiled and can run correctly in Jetson.

Attach my log for your reference. (Please make sure that Jetson enters forced-recovery mode before running the command.)

In Host PC:
[i]./_out_tools/tegrarcm --bct=_out/jetson-tk1/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct --bootloader=_out/jetson-tk1/u-boot-dtb-tegra.bin --loadaddr=0x83d88000
bct file: _out/jetson-tk1/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
booloader file: _out/jetson-tk1/u-boot-dtb-tegra.bin
load addr 0x83d88000
entry addr 0x83d88000
device id: 0x7140
uid: 0x34001001740970420800000008fe8300
RCM version: 64.1
downloading miniloader to target at address 0x4000e000 (136920 bytes)…
miniloader downloaded successfully
Chip UID: 0x00000001740970420800000008fe8300
Chip ID: 0x40
Chip ID Major Version: 0x1
Chip ID Minor Version: 0x1
Chip SKU: 0x81 (t124)
Boot ROM Version: 0x1
Boot Device: 0x2 (EMMC)
Operating Mode: 0x3 (developer mode)
Device Config Strap: 0x0
Device Config Fuse: 0x0
SDRAM Config Strap: 0x3
sending file: _out/jetson-tk1/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct

  • 8192/8192 bytes sent
    _out/jetson-tk1/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct sent successfully
    sending file: _out/jetson-tk1/u-boot-dtb-tegra.bin
    / 464216/464216 bytes sent
    _out/jetson-tk1/u-boot-dtb-tegra.bin sent successfully[/i]

Jetson UART log:

[i]U-Boot SPL 2014.10-rc2 (Dec 09 2015 - 11:22:53)

U-Boot 2014.10-rc2 (Dec 09 2015 - 11:22:53)

Board: NVIDIA Jetson TK1
I2C: ready
MMC: Tegra SD/MMC: 0, Tegra SD/MMC: 1
*** Warning - bad CRC, using default environment

tegra-pcie: PCI regions:
tegra-pcie: I/O: 0x12000000-0x12010000
tegra-pcie: non-prefetchable memory: 0x13000000-0x20000000
tegra-pcie: prefetchable memory: 0x20000000-0x40000000
tegra-pcie: 2x1, 1x1 configuration
egra-pcie: probing port 0, using 2 lanes
tegra-pcie: link 0 down, retrying
tegra-pcie: link 0 down, retrying
tegra-pcie: link 0 down, retrying
tegra-pcie: link 0 down, ignoring
tegra-pcie: probing port 1, using 1 lanes
In: serial
Out: serial
Err: serial
Net: RTL8169#0
Warning: RTL8169#0 using MAC address from net device

Hit any key to stop autoboot: 0
Tegra124 (Jetson TK1) # [/i]