Really Strange Testing Results

I am on Ubuntu 16.04.2 with a GTX 770 using NVIDIA 375.39 repackaged (I’m told there is 0 code changes, just packaged for easier install) from the “official” unofficial Graphics Driver PPA located here:

The PPA owner told me to post here about this issue after my email correspondence.

When I was using 375.26 I had no problems with my test results. I have a comparison between 375.26 and 378.09 here:

From that, you can see that 375.26 had very good frame rates across the board. While testing 378.09 I had pretty bad performance. What’s interesting if you notice though, my clocks don’t seem right when I ran 378.09.

I went down to 375.39 and did the same test.
Here it’s just like 378.09 but this time the clocks are read normally. Performance is still bad.

I thought this was really strange so I purged the driver packages (every NVIDIA thing I could find I had installed) then rebooted, then reinstalled, then rebooted, then ran my test. Here was the result:

Same exact numbers. I noticed they had an update to 375.39 but I think it was just a version change since 16.04.2 came out. This is the result:

Here’s the weird part though. If I run my test suite with JUST Unigine Valley the performance doubles and is very similar to my good 375.26 results!

How does this make any sense? Does anyone have any ideas? Is the GPU not clocking correctly when going from test suite to test suite? Is 375.29 a magical driver for me or did upgrading it to 378.09 do something bad?