Remote Desktop - CUDA

Okay, I think I know what the problem is with this but I am at a loss how to fix it currently. I am trying to run CUDA programs from my computer at work via my laptop using the Remote Desktop program. I can connect to the remote PC at work without any problem (no VPN needed) but when I try and run CUDA code on my Work PC using the remote client on my laptop I get the “NO CUDA Device found error”. The program works fine from the actual computer itself so I am figuring that the remote client is using my laptop’s GPU (an ATI) instead of the actual NVIDIA card on my work PC which runs the CUDA program.

I am using the GPU as a Co-Processor, so I do not need graphics per say from the Work PC - I just want to somehow force the remote client to actually use the NVIDIA Card on my Work PC rather than some emulated device. Is this possible? I have tried to use a VPN but could never seem to get it to work.

Does anyone know of a way to fix this problem? If so could you please give me some help?

Thank you.

This is fixed for Tesla cards on Vista/Win7 and similar OSes in an upcoming release. In the interim, you can use VNC instead of Remote Desktop.

(Remote Desktop inserts its own graphics driver)

Good to hear that the issue is fixed.

I am a little inexperienced with using the VNC as a remoting device, can you lend me some information on this? What is the best VNC where the computer that I will be connecting to remotely is a Windows XP 64 OS and the laptop I am using to connect with is a Vista OS?

Thank you.

Never Mind, I seem to have fixed it. After much searching I decided to go with the RAdmin program server/viewer it runs on XP and Vista. The viewer is free, the server is not but has 30 days free - I will see if my employer will cover the cost (it isn’t too much).

Thanks again.

Will this be fixed for the GTS/GTX series?

In which version has it been fixed?

FYI, the general CUDA computing forum,
http://forums.nvidia.com/index.php?showforum=64
still has a version 2.1 FAQ as a sticky, and that FAQ still lists Remote Desktop as a problem. It would be nice if that FAQ were updated to describe which problems have been fixed and which problems still exist, for example, the Timeout Detection and Recovery issue with Vista. Is that still a problem?