Remote Desktop - Jets1on TX

Good afternoon, all!

Been having a blast exploring the TX1 and many of its amazing abilities.

I am running an older MacBook Pro with Ubuntu 16.0.4, and have been trying to get remote desktop access to my TX1. I have Remmina Desktop Client installed on both machines, and desktop sharing is enabled on the Jetson. When I attempt to connect via VNC, it discovers the Jetson on the network and advises that it is connected at its static IP address.

The desktop that appears in Remmina on my MacBook, however, is black. No applications visible, nothing.

I have been reading extensive threads on this very topic, and the impression I get is that I have to install a “dummy monitor” on the TX1 in order for it to load the Ubuntu desktop in a useful fashion.

Is this correct?


Hi jhuds65,

I doubt what will show if there is no display in remote side. Tried this on my desktop and never succeeded if there is no HDMI connected to tegra.

I don’t know about the particular software, but unless X has a DISPLAY to render to, it won’t have a framebuffer. X doesn’t really care if the framebuffer is from a server which a display connects to, or if it is a server purely in RAM. You would need a virtual desktop server to use the GPU or remote desktop software when there is no physical monitor.

Is it possible that this approach might work?

ROS will likely be installed on the TX1 later on, and I suppose then I could just have the MacBook subscribe to a video topic published by the the Jetson, but I was looking for a solution in the interim.

AllowEmptyInitialConfiguration lets X start without something to display to…at least nothing configured. If you use some software which requires a display, then you still need either a virtual desktop or a real desktop…empty configuration lets you specify configuration late instead of early.

I’ve never used ROS, but many others here have. Someone who has experience with that might offer information on how they dealt with virtual versus hardware displays.

@jhuds65 I’ve seen it work in the past:

Kangalow’s solution is providing a virtual display to display controller and framebuffer. Looks like a valid workaround.

Thanks for the input, Kangalow, this is the method that I thought would work. I went in to edit the file
/etc/X11/xorg.conf and found that it was already configured as ‘Option AllowEmptyInitialConfiguration=“True”’ as mentioned in the JetsonHacks post.

All that being said, I am still getting just a black screen when using Remmina desktop.