Cannot remote desktop connect into Jeston Xavier NX from a ubuntu 20.04 using VNC

I have been trying to connect via remote desktop into my Xavier NX using the realVNC or vino on it and remmina and/or VNC viewer on a ubuntu 20.04 machine. I have been able to ssh into the xavier NX, but, cannot remote desktop. Are there any step-by-step instructions available for this setup?.

All i need is a working remote desktop application setup that works with the Xavier NX board. No preference as log as it works.

Thanks in advance.

Please try these steps on your NX.

  1. Default jetapck setup
  2. export DISPLAY=:0
  3. gsettings set org.gnome.Vino enabled true
  4. gsettings set org.gnome.Vino prompt-enabled false
  5. gsettings set org.gnome.Vino require-encryption false
  6. /usr/lib/vino/vino-server

Thanks for the input. I have tried the steps listed out, I have the following output on the last step.

Unable to init server: Could not connect: Connection refused
Cannot open display:
Run ‘vino-server --help’ to see a full list of available command line options

  1. Please do not run as a root in this step.
  2. export DISPLAY=:0 or :1 and run xrandr to see which one can give you result.

“Can’t open display 0”

“Can’t open display 1”

Here’s the response that i get from ‘xrandr’ after i execute it.

and, i’m not running as root as well

Do you have a monitor connected there?

yes. I am connected via a hdmi to a monitor and also an SSH connection from my other laptop. Have tried it in both.

Do you see ubutnu desktop on your monitor?

yes. i am able to use the Xavier device with a ubuntu desktop on a monitor just fine. nothing seems odd.

On the actual GUI login, what do you see from “echo $DISPLAY”? When running anything from any method other than direct login to the GUI, then that is what you should set as DISPLAY, and you must be logged in as that user. If ssh, then you must not use either of the options “-X” or “-Y”.

Hello @WayneWWW . i have got the steps to work. what next?. what are my next steps?

That helped me resolve the issue. thanks @linuxdev


If the vino server is launched, then you can try to use VNC client to connect it.

sometimes some clients also might throw error due to security something
in such case remmimma client is advised to try as it would work with vino withoout modifying server security settings