Is Jetson compatible with Ubuntu 18.04.1? Desktop Sharing appears broken?

After install of 4.1.1 DP (host computer is Ubuntu 18.04.1, every time i try to launch Xavier Desktop Sharing application it either crashes or does not launch… what is going on? Is anyone else seeing this?

Hi asrocki, see here for the Ubuntu Remote Desktop fix: https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1741027/comments/11

I followed the steps, but still has issues…

When attempting to use the any version (including latest of vnc viewer (by RealVNC)) I get the following error:

“Unable to connect to VNC Server using your chosen security setting. Either upgrade VNC Server to a more recent version from RealVNC, or select a weaker level of encryption.”

In the “Desktop Sharing Control Panel”…

I made sure to check boxes for “Allow other users to view your desktop” and “Allow other users to control your desktop”.

Under Security there are three options:
“You must confirm each access to this machine” (I originally kept the default checked, then left unchecked)
“Require user to enter this password” (I tried both keeping this checked, and unchecked)
“Automatically configure UPnP router to open and forward ports.” (I tried checking and unchecking this)

Nothing worked. When I attempt to connect, I do see in the Terminal where Vino was launched (using /usr/lib/vino/vino-server) that there was some attempt at connecting… but on my client I just see the same error at the top of this specific post.

What more do I have to do to get this working? I’m surprised simple/general TightVNCServer does not work either. If the Ubuntu Desktop Sharing is the main way to do it, please help me get this working.

By default Ubuntu Desktop Sharing has encryption enabled. You need to either use a client that supports encryption, or disable encryption on the remote host’s Vino server. I have heard that TeamViewer and Remmina clients work with encryption.

To disable encryption in Vino (Ubuntu Desktop Sharing), run this on the Jetson:

$ gsettings set org.gnome.Vino require-encryption false

To confirm the encryption setting is disabled:

$ gsettings list-recursively org.gnome.Vino | grep encrypt org.gnome.Vino require-encryption

Or if you prefer, you can disable it in the GUI via dconf-editor, as seen here:
https://www.hagensieker.com/wordpress/2018/04/27/how-to-do-screen-sharing-on-ubuntu-18-04/

[b]Now the screen sharing panel in unity-control-center works… but this is not enough to get vino running! So you need to add in the programs at session start: Vino-server with the following command line:

/usr/lib/vino/vino-server[/b]

how to add vino to the session start ???

Same issue. I’ll try the Ubuntu fix. I’m using a manual fix at the moment by issuing these two commands and then starting vnc manually.

gsettings set org.gnome.Vino require-encryption false
gsettings set org.gnome.Vino prompt-enabled false
/usr/lib/vino/vino-server

Tried the Ubuntu fix and now the blessed Desktop Sharing widget actually opens. Excellent.

to setup vino, I go to File=>Other Locations=>L4T-README=>README-vnc.tx and follow the instructions in the readme. If you are able to connect and found it’s view-only, then you need one extra setting in addition to all the settings in the readme:

gsettings set org.gnome.Vino view-only false

and reboot.

1 Like