Jetson AGX Xavier Developer-Kit - Using VNC (vino) over Hotspot (Ubuntu 20.04)

Hi,
I want to access the Jetson AGX Xavier Developer Kit remote via VNC over Hotspot.

I set up the Board with Ubuntu 20.04.

Additional Hardware Components:
→ HDMI-Dummy: HDMI Dummy Plug Headless Ghost Display Emulator Premium Aluminum PC(Fit Headless-1920x1080 New 4RD@60Hz) (DP-1P)
→ WiFi-Adapter: INTEL AX200 WLAN-Adapter,M.2 2230 Card, Wi-Fi 6

I setup the Hotspot from the NVIDIA as following:

nmcli device wifi hotspot ifname wlan0 con-name Hotspot ssid "HOTSPOT_NAME" band bg channel 3 password "PASSWD"
nmcli connection modify Hotspot ipv4.method shared ipv4.addresses 192.168.0.1/24 ipv4.gateway 192.168.0.1

nmcli connection up Hotspot
nmcli connection show --active

# connect automatically to hotspot at startup
nmcli con modify Hotspot connection.autoconnect true

sudo reboot

I can now access the nvidia Board via ssh:

ssh <user>@192.168.0.1

The setup of the Hotspot was done successful i guess.

Now I want to create a VNC-Server.
With the help of the Tutorial Setting Up VNC | NVIDIA Developer i created the VNC-Server:

cd /usr/lib/systemd/user/graphical-session.target.wants
sudo ln -s ../vino-server.service ./.

gsettings set org.gnome.Vino prompt-enabled false
gsettings set org.gnome.Vino require-encryption false

# Replace thepassword with your desired password
gsettings set org.gnome.Vino authentication-methods "['vnc']"
gsettings set org.gnome.Vino vnc-password $(echo -n 'thepassword'|base64)

sudo reboot

With a second PC (Ubuntu 20.04 / Windows11) i plugged into LAN (Internet) and connect additionally over WLAN to the Jetson-Hotspot.
After checking, if ssh works, i started remmina.
I connect to IP 192.168.0.1 over VNC using username and password.

Now comes the weird part.
I cannot connect to the Jetson unless it is plugged as well into LAN (Internet).

Summary:

  • VNC works fine: LAN-Connection (Jetson & Linux-PC), Hotspot-Connection (Jetson & Linux-PC)
  • VNC works fine: LAN-Connection(Jetson), Hotspot-Connection(Jetson & Windows11-PC)
  • VNC works not: LAN-Connection (Linux-PC), Hotspot-Connection (Jetson & Linux-PC)
  • VNC works not: LAN-Connection(none), Hotspot-Connection(Jetson & Windows11-PC)

I hope you can help me establishing the VNC-Connection over Hotspot with no access to the internet… A physical connection to the Jetson is not possible. It should be run completely remote and be fully accessible because it is implemented in a robotic environment.

Best regards
Luca

Hello,

Your topic belongs in the Jetson forums. I will move this over for you.

Tom

In addition to my previous post i want to give you the information that I also tried VNC over a external router.

I followed these steps:

  • disabling the Hotspot
nmcli connection down Hotspot
  • connecting to router with both clients (Jetson & external PC)
  • getting IP-Address
ifconfig
  • connecting to the IP-Address via vnc

I have the same error which means that something is wrong with the vnc-setup. Currently i need obviously internet-access. Do you know how to fix my problem?

Best regards
Luca

I disconnected the LAN again and then established a wired-connection between the router and the Jetson. It works again…

But i have still the issue, that i want to get rid of the cable to the router.

I found out that the settings to “Screen-Sharing” in Ubuntu offers only “Wired”-Conenctions.
Screenshot from 2023-08-04 13-27-18
Do you know how i can establish a wireless screen sharing connection?

Thanks again.

Hi werthmannlu75012,

What’s your Jetpack version in use?
Could you share the result of the following command?

$ cat /etc/nv_boot_control.conf

Is this your expected use case?
Can you use ssh on your host to log-in to your board at this moment?

Hi,

I tried it with the Jetpack Version 5.0.2 and t he latest 5.1.2

$ cat /etc/nv_boot_control.conf 
TNSPEC 2888-400-0004-K.0-1-2-jetson-agx-xavier-devkit-
COMPATIBLE_SPEC 2888-400-0004--1-2-jetson-agx-xavier-devkit-
TEGRA_CHIPID 0x19
TEGRA_OTA_BOOT_DEVICE /dev/mmcblk0boot0
TEGRA_OTA_GPT_DEVICE /dev/mmcblk0boot1

I can ssh into my Jetson Board at any moment and with all shown cases above.

Best regards
Luca

I found the issue is caused from vino-server not running automatically when you are using wireless hotspot so that the board is not listening on port 5900.

You could run the following command to check if the board is listening on port 5900.

$ netstat -an | grep 5900

You could run the following command to run vino-server in background.

$ DISPLAY=:0 /usr/lib/vino/vino-server &

Hi,

that muss be an issue specific for vino…
I switched now to a x11vnc-server that is able to run at autostart and is capable of using the wifi-interface.

Additional Informations:

Thanks for you help anyway :D
Luca

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.