Unable to run remote desktop

I have a new Jetson AGX Orin dev kit. It is connected to a monitor, keyboard and mouse via a KVM. Jetpack was used to install all needed software and system works well.

I am able to do most tasks via a SSH session, however, I have a few tasks I need remote desktop access.

I followed the instructions on this page: trying to connect to it via a and have installed RealVNC on my remote laptop. My colleague in the office shared these screenshots, confirming OS Sharing settings:

However, when I run RealVNC on my remote system to access my Jetson, it times out.

How can I fix this? What am I missing?

Hi sinha,

Are you using the devkit or custom board for AGX Orin?
What’s your Jetpack version in use?

Have you tried VNC Viewer?
Does your board connect to a physical monitor?

Hello. Thank you for reply. Below are answers to the questions and some extra information.

  • I am using the NVIDIA dev kit.

  • Jetpack info:
    Package: nvidia-jetpack
    Version: 5.1-b147
    Architecture: arm64
    R35 (release), REVISION: 2.1, GCID: 32413640, BOARD: t186ref, EABI: aarch64, DATE: Tue Jan 24 23:38:33 UTC 2023

  • Before running RealVNC I ssh into the machine and run the following commands:
    systemctl --user start vino-server
    sudo netstat -tulpn | grep LISTEN (to confirm the server is launched )

  • I have tried VNC Viewer. I am using

  • My AGX Orin board does connect to and display on a physical monitor.

I would suggest updating to the latest JP5.1.2(R35.4.1) to verify.

Please check if the vino server is running as expected.

$ systemctl --user status vino-server.service

and check if it is listening on port 5900

$ netstat -an | grep 5900

Could you see the remote desktop through VNC Viewer now?

What I am using is “VNC Viewer”.

Thanks for the additional information.

At the moment I cannot update with latest JetPack. The system is in use and needs to maintain its configuration.

I have, however, done the extra steps you suggested.

Here’s what I see when I execute: systemctl --user status vino-server.service

Here’s what I see when I execute: netstat -an | grep 5900

I tried a down rev version of VNC Viewer (v 6.22) and had same time out error:

Based on the first two screenshots, is the vino-server IP addr incorrect?

Also, port 5900 is not blocked in my local network.

Could you use VNC Viewer instead of RealVNC Viewer?

It should be fine.

Could you check the status of vino service on your board after you hit the timeout error?

$ systemctl --user status vino-server.service

Thanks again for feedback.

I found a the same version of VNC Viewer in your screenshot:

I tried connecting to my Jetson AGX Orin, and am still encountering a time out error:

After time out pop-up window, I ran: systemctl --user status vino-server.service

Any other ideas suggestions to get this working will be greatly appreciated.

I am curious…if you monitor “sudo tail -f /var/log/auth.log”, and then try to log in, does anything show up as a result of trying to log in?

Also, the log name for an X server depends on the context (which in turn is what the “$DISPLAY” is, and there can be more than one DISPLAY context). What do you see for log files from:
ls -ltr /var/log/Xorg.*.log
(this is for current boot logs, and the one listed last is the one most recently updated)

Check the ls -ltr /var/log/Xorg.*.log before trying to log into the X server, or at least before attempting the login via remote desktop, and then again after remote desktop login attempt. Does the timestamp on the most recent log change?

Thanks for the additional debug suggestions.

Per your suggestions, I opened an SSH session to the target device, then ran the suggested commands while attempting to open a VNC Viewer client session.

For the first check,

sudo tail -f /var/log/auth.log

Oct 5 12:36:54 mtec1-desktop sshd[24958]: Accepted password for mtec1 from port 60066 ssh2
Oct 5 12:36:54 mtec1-desktop sshd[24958]: pam_unix(sshd:session): session opened for user mtec1 by (uid=0)
Oct 5 12:36:54 mtec1-desktop systemd-logind[1018]: New session 454 of user mtec1.
Oct 5 12:46:59 mtec1-desktop sudo: mtec1 : TTY=pts/0 ; PWD=/home/mtec1 ; USER=root ; COMMAND=/usr/bin/tail -f /var/log/auth.log
Oct 5 12:46:59 mtec1-desktop sudo: pam_unix(sudo:session): session opened for user root by mtec1(uid=0)

I did not observe any updates / changes as a result of (trying to) connect with VNC Viewer.

For the second check, I observed no change to timestamp on the most recent log, before trying VNC Viewer login and after.

ls -ltr /var/log/Xorg.*.log



Could you try if the following commands help for your case?

$ gsettings set org.gnome.Vino require-encryption false
$ DISPLAY=:0 /usr/lib/vino/vino-server &

I tried the recommend commands. I assumed I was to run the commands in a SSH session before retrying VNC Viewer.

First command executed with no warning or errors.

Second command had errors:

The way you indicated to start the vino-server seems to have issues. The following command however seems to start the server: systemctl --user start vino-server

To avoid any confusion, the computer I’m using to run the remote desktop client is running Windows 10.

Windows 10 should be good to work with VNC Viewer.

What’s you custom configuration on this devkit?

Do you have another devkit could flash the clean JP5.1.2 to verify?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.