Setting up VNC server (Solved)

Upon powering up the Xavier, it exports a folder with a few user manuals.

README-vnc.txt explains how to set up a VNC server.

From the manual, ‘gsettings set org.gnome.Vino enabled true’ did not work and returned an error like this.
No such key “enabled”

Looking at Vino wiki page, it seems that ~/.config/autostart/vino-server.desktop needs to be created with the following content.

[Desktop Entry]
Type=Application
Name=Vino VNC server
Exec=/usr/lib/vino/vino-server
NoDisplay=true

After that, I could access the Xavier through VNC viewer.

Hope this helps.

1 Like

Thanks hackbin. For those trying to use the ‘Desktop Sharing’ GUI tool in Unity to enable remote desktop, you may have to perform these steps: https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1741027/comments/11

/usr/lib/vino/vino-server

When I run this on the terminal, it gets stuck at

Listening IPv4://0.0.0.0:5900

Its been stuck on this line for over 15 hours. Is there a way to fix this problem?

Hi udaikp,

Please open a new topic for your issue. Thanks

1 Like

The Gui Desktop Sharing Tool. Share Desktop Slider does not stay “ON”, slides back to OFF. Reading somewhere else this behavior has something to do with adding the network connection UUID. If so, please provide procedure?

This problem resolved after the next boot. From gnome desktop, search for Desktop Sharing app brings up its GUI. Enable "Allow others to view your desktop and Allow others to control your desktop. “Security Require the user to enter this password ******” (Enter your desired VNC pw)

Opening MACOS Screen Sharing , entering IP Adress and VNC pw open the Ubuntu Desktop window.