Unable to setup Remote Desktop session

I’m new to Ubuntu and am trying to setup my TX2 to run without a monitor or keyboard and mouse.
I’ve tried setting up a remote desktop session by installing Vino.
I’ve tried running “vino-preferences” from the command line but I get an error saying ‘command not found’ even though the vino server is running.
I’m also unable to allow for “other users to view your desktop” from the “System Settings” UI. I click on the “Desktop Sharing” icon and System Settings crashes.

When attempting to use Remote Desktop from a Windows machine, I can start the login process and then the remote desktop connection closes/ crashes.

This is a newly flashed TX2 with Jetpack 4.5.1 and Ubuntu 18.04 installed on the TX2.

It is a known issue that the default vnc does not work without monitor.

I have a monitor connected though … and I can log in locally (as in, this also does not work if I have a keyboard and mouse connected)

I’ve also attempted to use XRDP … and no dice.
It just sits there and looks like it’s trying to log in over a super slow connection…