Remote Desktop/XRDP

I’ve been trying to get XRDP working on the Jetson TX2 dev board. I have a brand new NVIDIA dev board, and I installed XRDP following the instructions here:

After installing, I logged out of my account and tried to log in remotely. However, when I log in remotely, the NVIDIA logo flashes for a second, and then I get booted off. Has anyone gotten XRDP working, and if yes, how did you do it?

If you stay in login state, will you see the xrdp desktop correctly?

When I login from Windows10 Remote Desktop, I see this

When I enter the credentials, the NVIDIA logo flashes and then the window closes.

I mean if you connect a HDMI monitor and stay in login status on that monitor.

The physically connected monitor just stays in the regular login screen.

I should make a more clear comment. Not just login screen.
If you physically monitor is on “ubuntu desktop” (already login with the correct user account and password), will the remote one able to get access?

No, it doesn’t work. On the session in the local desktop there is no indication that someone is trying to remote in either.

Would you mind using vino vnc at this moment? Vino is verified working and is our official support.

Thanks for the suggestion, I have VNC working. However, VNC doesn’t
start until you’ve logged in at least once, which means I have to
enable auto log-on . It’s also quite laggy, I was hoping RDP would
have better performance. I hope we can find a fix for this.

I am not sure the meaning of “you’ve logged in at least once”. What does that mean? I think xrdp requires that too.

The VNC server doesn’t start until you’ve logged in. Maybe xrdp
requires that too, but I can’t test obviously.

I just tried Vino with my nano in office and it does not need to be logging on nano side.

Need set below on your nano using ssh first.

gsettings set org.gnome.Vino prompt-enabled false
gsettings set org.gnome.Vino require-encryption false

That works, thanks!