Issue with xrdp

I’ve recently set up my jetson nano for a project I’ll be working on. I installed xrdp on jetson nano and tried to connect through the host machine using remmina. Everytime a connection is made a window briefly shows up with the same nvidia logo as the login screen and then the rdp session exit itself. Am I missing something here? I set both the host and the jetson nano to be local link only and the xrdp session should be through ethernet. I also made sure I wasn’t logged in on jetson side.

1 Like

Could you share your step of installing/connectiong xrdp?

Not much went into the setup during the entire process. I used the package from the Debian repository (xrdp was installed directly using get) and that’s it on the jetson nano’s side. The jetson is connected through an ethernet cable to the host pc. 'Im using remmina for rdp and just filled in the necessary details for connection (I used nmap to check and make sure the ports are open for the rdp and I did not log in on the Jetson Nano’s side). If I missed anything would you be willing to point them out? Thanks!

Hi macvacaent,

Please share what Debian repo you are using and what command is using to install xrdp.

Sorry for not clarifying those earlier. I used the recommended image for jetson nano on the download page and I installed xrdp using “$sudo apt-get install xrdp”

Got it. Do you connect any monitor there?

nope, boot it up without monitor and I used nmap to check the xrdp server is running

Could you try to connect a monitor and see if xrdp can work with monitor? If it can, then it means we need some configuration with no monitor case.

i have the same problem .can explain how it can be solve?

Just tried, still doesn’t seem to work. I’ll take some time tonight to find the log file and see what I can do.

After installing Microsoft January 2020 Patch, I had problems logging into the jetson nano via xrdp. I get the nvidia logo and the session terminates

1 Like

Interesting, my host pc is on ubuntu 18.04. Xrdp works fine on both Pi4 and Pi 3b+ though.
Maybe I should try to rollback to an older version of xrdp since there was an update recently that might not play nice with the Jetson Nano:

https://launchpad.net/ubuntu/+source/xrdp/+changelog

nol older version, reinstalled and still no dice.

It could have something to do with this:
https://arstechnica.com/information-technology/2020/01/another-reason-to-hurry-with-windows-server-patches-a-new-rdp-vulnerability/

If Microsoft changed the way rdp works, it possibly broke xrdp from patched Windows clients. New vulnerabilities for rdp are always being found.

Getting this error “unable to locate package xrdp” while installing xrdp in Jetson Nano.
Please help.
Thanks in advance

Please give solution for this problem

what if you use other remote desktop servers/clients? or your choice is limited only to xrdp? what about nomachine? vnc, x2go?

That’s a good suggestion, Andrey. I use ssh -X for nearly everything, but it is not suitable for graphics heavy apps or slower internet. Most people seem to use vnc, but the encode is done in software on nano, I believe. I have never tried x2go.

I believe there’s an issue logging in via RDP while there is an SSH connection open, maybe that’s related.

I have the exact same problem: Microsoft Remote Desktop opens a window on my Mac which for 1s shows the Nvidia logo, then closes unexpectedly. I am using the Nvidia image on my Jetson nano and Microsoft Remote Desktop for Mac. Did you find a solution to the problem? Thanks!

1 Like