Nvidia logo flashes before disconnecting after login on remote desktop - Jetson Nano

I’ve been trying hard to open a remote desktop connection to my Jetson nano but getting these errors.

  1. I open Remote desktop on my windows machine and enter the IP address of my jetson nano. I click connect
  2. I enter the user name and password. the screen flashes the nvidia logo for a second and it disconnects.

What all i have already tried.

  1. Have tried the solution mentioned here
gsettings set org.gnome.Vino prompt-enabled false
gsettings set org.gnome.Vino require-encryption false 
  1. I’ve tried reflashing the nano several times but same problem persists

  2. I tried the xfce4 environment , it worked but i don’t want that.

Will be grateful for any help. I setup my jetson nano only via micro usb and a ethernet cable to my laptop.

Is your jetson nano connected with a desktop?

Yes it’s connected to an external monitor. But i need a desktop environment through a xrdp. I tried the solution provided here - Issue with xrdp. It did work but with xfce. So I reflashed my Jetson and installed xrdp again but having the same problem.