Remote Access to Jetson Nano

Hello, I want to access the Jetson Nano via remote desktop.
The following considerations:

  • I tried VNC, but it is really slow.
  • I cannot get TeamViewer to work.
  • I tried installing Xrdp. After “Remote desktop Connection” requests my password(see attached image), the program exits.

If you have an fast remote alternative let me know please.

Thank you!

Hi,

are you logged in on the Jetson Nano, when you try to connect via remote desktop?

When I´m right, you can only be logged in directly on the Jetson Nano GUI (via DP or HDMI), or via remote desktop. So, log out on Jetson Nano and try again via xrdp/remote desktop.

Best regards,
Lars

If you’re on the same wired local network, ssh -X works, but you should be aware that the graphics are being rendered on your local X server in such a case, so if you launch an OpenGL game for example, it’ll use your local virtual graphics hardware, which means your local CPU in most cases. Cuda, however, will be done on the nano.

To launch a program remotely from a linux computer:

ssh -X some_user@test-jetson -C gedit

Where gedit is the program you wish to run. You can omit -C get straight to a ssh prompt with X support. Any graphical applications you launch will pop up on your screen automatically.

Please note that X does not need to be running on the Nano, so if you want to save a whole bunch of memory while working remotely you can run sudo systemctl isolate multi-user.target to temporarily shut down the graphical environment on the Nano itself.

To remotely access from windows, here are instructions on how to set up an X server on windows and connect it to Putty, but please note those instructions have an old download link. A new one is here.

1 Like

Thank you. It seems that I just needed to be logged off.

Late reply but I recommend trying out NoMachine for ARM ARMv8 DEB ( https://www.nomachine.com/download/linux&id=30&s=ARM ) as an alternative to teamviewer.

1 Like

Has anyone managed to get NoMachine ARMv8 DEB to work on the Jetson Nano? When I installed the DEB file, and tried to log in, all I get is a black screen. The mouse cursor does change from pointer to cursor when I hover over where a terminal, but the actual screen is not rendering.

I got mine to work with Jetson Nano (with a monitor plugged in, non-headless mode). I can remote into the Jetson nano from a Windows 10 machine and also from an iPad using the NoMachine software.

Never experienced black screen unless my monitor was unplugged (headless-mode), in which case I had to do apply the “multi-user.target” commands from this thread (and maybe install an x-server somewhere along the way if necessary):
https://devtalk.nvidia.com/default/topic/1049266/jetson-nano/headless-os/2

Hi Jarosky

Would you be so kind as to describe the steps needed for remote access to the jetson nano in more detail?

Thanks,

sojohan

no worries it works now…sojohan

I am not logged in, but I get the same screen as at the start of this thread. I have installed a wlan card and also tried to connect over ethernet, but not able to use the remote desktop.

I have even tried disabling the wlan0 while i am on ethernet.

How do i ensure I am logged out?
To make sure i am completely logged out I simply restarted :

sudo shutdown -r now

But that didn’t help.

When a monitor is not plugged in, did you have to use
sudo systemctl isolate multi-user.target

or
sudo systemctl isolate grahical.target

to get NoMachine to work?

Actually I get a black screen, after the login screen same as above.

Hi,

I also used Xrdp to get remote control but it was so so so slow. Did you get the same problem? or do you have any ideas about the issue? Thanks!

I permanently fail with xrdp. My windows systems shows shortly the nano desktop and than break. The same happens if I am logged-in or logged-out. I am hardwired in the same network. The remote desktop mask in “settings” could not be opended.

Are there any easy description how to install xrdp on jetson nano?

I had issues as well with a brand new install. Followed this advice and fixed it - https://github.com/neutrinolabs/xrdp/issues/1294

Danke für den Hinweis, aber das Problem liegt schon früher.

Statusinformationen werden eingelesen… Fertig
E: Paket xrdpxorg kann nicht gefunden werden.

Danke für den Hinweis, es scheint aber so, dass man mit der Standardinstallation von NVDIA nicht auf die Server kommt.

Danke
Hans-Leo Ross

consider the fork of the NoMachine, X2go

Can u please, guide me through the steps to install vnc on jetson nano?

I used this steps:

Now I am using nomachine, which works faster than VNC and it is way easier to setup