Has anyone had success installing NoMachine on their Nano?

I managed to install the ARM8 .deb version on my Nano, but I can’t seem to log into my Nano from my main Ubuntu system. https://www.nomachine.com/

I appear to log in, but I get a blank screen in the viewer.

Anyone else have success?

Thanks.

Hi ACallum,

We haven’t tested the NoMachine on Jetson device yet, hope other developers could share their experience if they did.

I am using often x2go that is a derivative of the NoMachine

this works fine:

https://www.nomachine.com/download/download&id=116&s=ARM

Installing NoMachine Instructions

*Or, in general, how to set up your Jetson Nano to work remotely.

  1. Download the package on your Jetson Nano

https://www.nomachine.com/download/download&id=116&s=ARM

  1. Install the package
sudo dpkg -i nomachine_6.8.1_1_arm64.deb
  1. Fix desktop sharing bug on Jetson Nano:
sudo gedit /usr/share/glib-2.0/schemas/org.gnome.Vino.gschema.xml
  1. Add this lines at the end of the file
<key name=’enabled’ type=’b’>
<summary>Enable remote access to the desktop</summary>
<description>
If true, allows remote access to the desktop via the RFB
protocol. Users on remote machines may then connect to the
desktop using a VNC viewer.
</description>
<default>true</default>
</key>
  1. Compile the previous file
sudo glib-compile-schemas /usr/share/glib-2.0/schemas
  1. Change Setup on System Settings -> Desktop Sharing as you like

  2. Fix small screen issue on headless mode:

sudo gedit /etc/X11/xorg.conf
  1. Add this lines at the end of the file
Section "Screen"
Identifier "Screen0"
Monitor    "Monitor0"
    SubSection "Display"
    Viewport   0 0
    Modes "1920x1080"
    Depth   24 
    Virtual 1920 1080
EndSubSection
EndSection
  1. Get your Jetson Nano IP: in front of inet, on wlan0 section (if connected wireless), running:
ifconfig
  1. Use your device’s IP to connect using Nomachine (the default device appearing on the program may not work)

  2. Obviously, install Nomachine also in your computer.

  3. Done :)

1 Like

I didn’t have to do anything aside from install the nomachine package.
(I did however assign the nano a static IP … but that’s just for convenience …)
nothing else though…
I’m using the dli image …

I had no luck.
on “R32 (release), REVISION: 3.1”
using “nomachine_6.9.2_1_arm64.deb”.

first I had a black screen.
then running startx, I had a black screen with nvidia logo, and no interaction.
then after doing matesanz.cuadrado steps.
I’m getting the purple velvety ubuntu background with no interaction.

Since my machine is headless, I’m not sure how to do step 6 “6. Change Setup on System Settings -> Desktop Sharing as you like” which is probably the culprit

i got it working using the dlinano image but when I tried again the other day on the regular image (using matesanz.cuadrado steps) I also just got the black screen with NVIDIA logo on it… haven’t had time to investigate further … I plugged the nano into a real display/keyboard to fiddle with the desktop settings…

Problems with creating session shows for me as well when I stopped Xserver. But it looks that there is problem with Unity. When I installed there xfce - sessions start worked. So there are two workaround - enable GUI or install other DE then unity based on GNOME.

fyi I have spent a lot of time trying everything else to access UI remotely as many it seems
For me only NoMachine worked. Using V8 (https://www.nomachine.com/download/linux&id=30&s=ARM)
using Jetson NX - Jetpack 4.4 L4T 32.4.2

1 Like

Hi, I need help for the NoMachine “black screen” problem. I want to open a remote desktop of a NX module from a Linux laptop (running Ubuntu 18.04). I tried both NoMachine and x2go. No luck so far.
The NX is a production module attached on a CTI Quark board, headless. I installed the JetPack 4.5 L4T R32.5 on it. Following the information on this thread, I first tried NoMatchine. Only get a black screen from my laptop client.
Then I tried the x2go. The client cannot complete the login step and returned the following message:

Session: Terminating session at ‘Tue Mar 9 18:02:03 2021’.
Info: Your session was closed before reaching a usable state.
Info: This can be due to the local X server refusing access to the client.
Info: Please check authorization provided by the remote X application.
Session: Session terminated at ‘Tue Mar 9 18:02:03 2021’.
Connection timeout, aborting

If anyone has successful experience, especially with NoMachine, please help with a detail instruction.

Thanks a lot.

P.S. I got NoMachine working on a NX DevKit, which has HDMI port on its carrier board.

I solved my problem with the instruction from this link:

Post it here just in case if anyone has the same issue.

1 Like