Jetson Nano Desktop Sharing Problem

Hi,

I’m new on Jetson Family. I want to use Desktop Sharing App like Team-viewer,Any Desk. I tried to install both of them. But some processor issues appear when I was installing. I want to connect my Jatson from my PC which is loaded with Windows OS.
I tried lost of way. But all ways related Linux on personal computer, I’m not found any information directly related Jetson Nano kit.

Could anyone help and suggestion me about situation?

Hi.

I use default Desktop sharing function.

This function get an error by default.

So, I try this .

https://blog.hackster.io/getting-started-with-the-nvidia-jetson-nano-developer-kit-43aa7c298797

-> Enabling Desktop Sharing

I can connect VNC remote connection.

so try it .

Ah.!! thank you @devemin. I was also try this enabling issues but the solutions I looked at did not work. I could try only firs part cause of workload. I think for more, it will help me too.

thank you again and again.

Teamviewer doesn’t install properly for me on Jetson Nano (it always crashes when you try to connect). AnyDesk is too slow.

The best I’ve found so far is NoMachine (NoMachine for ARM ARMv8 DEB, https://www.nomachine.com/download/linux&id=30&s=ARM ). It streams videos fast with low latency over LAN for me.

1 Like

Thank you @Pixol for your suggestion. I will try your solution too.

Thank you Pixol, my savior. At last, something worked. NoMachine rocks.

Maybe I should try Jetson Nano. I see people also praising it

Worked for me. Thanks.

Hi, I am a total noob. Trying to follow the same guide, but I am stuck at adding the “key” to the XML file. How do you do that? Do you need to specify a key name and type? Where do you add the suggested text?

Please clarify this for me, if you have a couple minutes! Thanks in advance!

Hi,

Please add the following to the xml and try again.

<key name=’enabled’ type=’b’>
<summary>Enable remote access to the desktop</summary>
<description>
If true, allows remote access to the desktop via the RFB
protocol. Users on remote machines may then connect to the
desktop using a VNC viewer.
</description>
<default>true</default>
</key>

Hi,
thanks a lot: it worked perfectly!!!

You rock!

/Pietro

Hi.

If you had installed with Anydesk. Please guide me how to install Anydesk in NVIDIA jetson nano. Orelse if there are any other options to share remote location please help !!