Issue with xrdp

I have the same problem using Microsoft Remote Desktop on Windows 10 and Remmima in Ubuntu.

1 Like

Logout from Jetson nano and try to login in remote connection.it will work

I encountered this issue today. It turns out it was caused by gnome (more specifically, the MESA GL library).

Didn’t want to waste more time on this. So I installed xfce4 and used it instead. That solved the problem.

Here are the steps:

  1. Install xfce4
    sudo apt install xfce4
  2. Comment out the last two lines in /etc/xrdp/startwm.sh
  3. Add the following line to /etc/xrdp/startwm.sh
    startxfce4
  4. Restart xrdp
    sudo service xrdp restart
16 Likes

Thank, xfce4 works!

1 Like

Works perfectly, thanks.

Obviously not the RDP patch issue mentioned above.

This worked, but there is an error when I try to run an application that uses the OpenGl

libGL error: failed to load driver: swrast
X Error of failed request: GLXBadContext
Major opcode of failed request: 154 (GLX)
Minor opcode of failed request: 6 (X_GLXIsDirect)
Serial number of failed request: 36
Current serial number in output stream: 35

This error does not happens when I am using the monitor.

Before I got this issue , I didn’t upgrade my ubuntu and the XRDP worked very good between windows and the Jetson. But then I decided to upgrade my distro to 18.04.4 LTS and this starts happening

although xfce4 desktop shell allows me to log in via MS RDP, it has several issues including unable to launch Terminal window and the shell hangs on occasion. Will be looking for a fix for default shell.

1 Like

please consider this before installing xfce4 ,

UI is lag, old and main important there is no synchronism to some applications(terminal mainly , etc), actions wont visible in RDP.

@WayneWWW
what is the use of these Forums, if you cant even give a resolution to main problem of XRDP connecting,
I had to waste more than 3 days in searching.

Hi,
We may not have experience in some software frameworks, but other users may see the post and share experience. My apology that we don’t have enough experience in xrdp. And thank other users for providing guidance. Much appreciation.

2 Likes

The solution for XRDP provided here is for ubuntu https://forums.developer.nvidia.com/u/jiang.guo
could any provide solution same for windows for connecting jetson nano through remote

Thanks man, this is working.
I have to do this too
echo xfce4-session >~/.xsession
by doing this we make sure that xrdp uses xcef4

I’ve tried SEVERAL different “fixes” for this issues. They didn’t work. But your DID! Thanks!

This worked for me too. Thanks for sharing this!

it didn’t happen that way.

sudo update-alternatives --configure x-session-manager

Run this in terminal and try forcing LXDE session by selecting lxde session. Reboot. It worked for me.

I opened this file /etc/xrdp/startwm.sh, but I’m not able to save it after changes. How you did?

@ansjaved67
Have you tried it with vim as sudo?:
sudo vim /etc/xrdp/startwm.sh

Then save with “wq”, worked for me.