Remote Display not loading with GeForce GT 710

I am having issues with my Linux Mint/Ubuntu system to properly display via a remote desktop connection - the system is using llvmpipe when logged in via remote desktop connection, but properly configures when connected to the system locally/in person. System details:

Linux Mint 19.2, Ubuntu 18.04
Kernel version: 4.15.0-189-generic x86_64
GPU: GeForce GT 710
Nvidia driver version: 470.141.03
Remote connection via XRDP

The nvidia-smi recognizes the GPU and does not return any errors.

Symptoms of the issue:

  • The physical/in person computer display works as expected. The issues described below are not present with the in person/physical computer display and only affect the remote connection display.
  • nvidia-settings outputs ‘ERROR: Unable to load info from any available system.’ The application attempts to open but simply creates a blank window.
  • data visualization program “Paraview” does not display information, although by left/right clicking on the display, the program provides dropdown menus indicating that the program has loaded but is not displaying the program information.
  • prime-select nvidia indicates that the nvidia profile is already set
  • inxi -G indicates that the renderer is using llvm. inxi -Gxx:
  Device-1: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI 
  driver: nvidia v: 470.141.03 bus ID: 81:00.0 chip ID: 10de:128b 
  Display: server: X.Org 1.19.6 driver: nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa compositor: marco 
  resolution: 3000x2000~50Hz 
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.8 
  compat-v: 3.1 direct render: Yes

I have already tried version 390 and the same symptoms were present. Attached is the report log when run via the REMOTE connection. I appreciate any help with identifying and fixing this issue as I’m not sure what to do next. Thanks.

nvidia-bug-report-REMOTE.log.gz (1.1 MB)

Thanks generix. Based on you linking that post, are you saying that there is no solution for this issue? I tried some of the suggestions in that post and other that were linked to that post and have not come up with a solution.

Would this solution linked below that you previously provided be appropriate in my situation?

See this for a simple solution:
Please read the whole thread to get the picture.

Thanks generix. I appreciate the direction and I was able to implement an adequate solution using x11vnc. For the benefit of others who may come across this post, this was my solution method:

  1. Understand that Nvidia graphics card seem to present issues with allowing remote connections to properly display on the remote connection when using a remote X display (as in with the built in Windows Remote Desktop Connection software). As a result, assuming the local X display is working as intended, the local X display must be forwarded to the remote client.
  2. The following links were helpful in setting things up. I used x11vnc and openssh-server on Ubuntu; Putty and TightVNC on Windows 10.
    Original author of x11vnc:
    Partially helpful directions on installing x11vnc:
    General directions on overall process:
    General directions on overall process:

Here are the steps that I took at a high level - see the links above for more detail:

  • Installed x11vnc and openssh-server on Ubuntu machine
  • Installed TightVNC on Windows machine
  • Locally log in to Ubuntu machine prior to attempting a remote connection
  • Configure Putty with SSH settings
  • Within Putty terminal, load x11vnc
  • Configure TightVNC with setup SSH settings
  • Input x11vnc password to login to TightVNC

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.