Repeated editor hangs using Eclipse 2021-12 Code editor to edit device code

I am trying to use Eclipse 2021-12 to edit device code. If I enter code, such as mismatched parentheses and save the source file, the editor hangs, I have to kill Eclipse and start over.

This is unacceptabe for a code editor. I have never had editor hangs editing C or C++ host code.

Can this be fixed? Is this editor even supported?

NVIDIA has not validated Eclipse 2021-12 yet. That being said, we have not noticed this type of error before during our validiation of previous Eclipse releases. Do you know if this is a newly-introduced regression? havew you tried this with Eclipse 2021-09?

Yes, this fails with 2021-09 as well. It also seems to have something to do with my editor save file actions which include reformat the entire source file when saving the file.

I installed Eclipse 2021-09 C++ developers package and then installed the Nsight plugins package from /usr/local/cuda-11.5/nsightee_plugins/

I have this source file

extern "C" __global__ void __closesthit__xx() {
                        optixGetPrimitiveIndex(, optixGetSbtGASIndex(), 0.0f, data);

Note missing ‘)’ in the optixGetPrimitiveIndex call.

If I save without auto formatting, there is no hang. If I right click, pick source and format entire file, then Eclipse hangs. I have also seen cases where a save with format with missing ‘)’ where the save takes several seconds instead of being instantaneous, and with misformatted source file, understandable because of the missing ‘)’

I’m not sure if that’s the full scope of the problem but something is badly confusing the source code formatter.

The other thing I have seen, which I have no idea how to pin down, is that after a number of edit/compile/run iterations, I notice one of the CPU cores is running constantly 100% with java (Eclipse) running 100% on that CPU, even when Eclipse is idle… It doesn’t seem to harm anything, but still should not be happening.

This appears to be still broken with the CUDA 11.6 update. Is there any intent to fix this bug? Editor hangs and losing code changes is a serious problem.

Thank you for the updated information regarding the failure on CUDA 11.6. We are investigating this failure mode and will reply back on this thread as soon as we’re able to replicate the results.

We have identified the issue and have implemented a fix. It is undergoing internal testing, and our plan is to incorporate this fix into the next release of CUDA. Thanks very much for your bug report, and for your patience while we worked to resolve this issue.

I reinstalled eclipse, but the problem still…
I put the log in a reply above (after nuking the error log, shutting eclipse, re-opening it, and putting a period after “this,” then exporting the log).

Regrettably, there is no option to erase one’s response…

The fix for this issue has been implemented, tested and will be included in the next release.

It looks like this is fixed with the CUDA 11.7 update, thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.