Repeating 30 times

Seriously, is there any official manual for setting the machine?
I’ve reinstalled for 30 times for installing librosa, llvm packages.

And now, tensorflow is not working !!!

Hi,

What is the problem do you meet when installing TensorFlow?
We have a prebuilt package for TensorFlow and you should be able to install it with the command here:
https://devtalk.nvidia.com/default/topic/1048776/jetson-nano/official-tensorflow-for-jetson-nano-/

We don’t include the installation steps of third-party library into our document but you can find some information here:
https://elinux.org/Jetson_Nano#Deep_Learning

Thanks.

me too, I have read and followed the following articles from krstyle03v.
https://devtalk.nvidia.com/default/topic/1051690/jetson-nano/instll-python-packages-librosa-and-llvm-on-jetson-nano-developer-kit-problem/post/5338129/#5338129

[url]https://devtalk.nvidia.com/default/topic/1051865/jetson-nano/fail-to-install-librosa-llvm-and-llvmlite/post/5339146/#5339146[/url]

jetson nano is not working, when installing libroa, llvm pacakges.
I did a lot of repetition, like manual build of llvm-7 but it still not workig.
please help and teach me and krstyle03v.

Hi,

librosa and llvm don’t support ARM platform.
It’s recommended to check with the company if there is an official release in the future.

Thanks.

I installed librosa 0.6.1 with llvmlite 7.0.1 guided by https://groups.google.com/forum/#!topic/librosa/xE5cR-EGWkM

However, the following error occurs when import librosa, like Unable to find target for this triple (no targets are registered).
How can I solve it?

Thank you.


log

shkim at csdl-nano1 in ~ $
→ pip3 install librosa==0.6.1
Collecting librosa==0.6.1
Collecting numpy>=1.8.0 (from librosa==0.6.1)
Collecting scipy>=0.14.0 (from librosa==0.6.1)
Collecting decorator>=3.0.0 (from librosa==0.6.1)
Using cached https://files.pythonhosted.org/packages/5f/88/0075e461560a1e750a0dcbf77f1d9de775028c37a19a346a6c565a257399/decorator-4.4.0-py2.py3-none-any.whl
Collecting resampy>=0.2.0 (from librosa==0.6.1)
Collecting numba>=0.38.0 (from librosa==0.6.1)
Collecting joblib>=0.7.0 (from librosa==0.6.1)
Using cached https://files.pythonhosted.org/packages/cd/c1/50a758e8247561e58cb87305b1e90b171b8c767b15b12a1734001f41d356/joblib-0.13.2-py2.py3-none-any.whl
Collecting scikit-learn!=0.19.0,>=0.14.0 (from librosa==0.6.1)
Collecting six>=1.3 (from librosa==0.6.1)
Using cached https://files.pythonhosted.org/packages/73/fb/00a976f728d0d1fecfe898238ce23f502a721c0ac0ecfedb80e0d88c64e9/six-1.12.0-py2.py3-none-any.whl
Collecting audioread>=2.0.0 (from librosa==0.6.1)
Collecting llvmlite>=0.28.0dev0 (from numba>=0.38.0->librosa==0.6.1)
Installing collected packages: numpy, scipy, decorator, llvmlite, numba, six, resampy, joblib, scikit-learn, audioread, librosa
Successfully installed audioread-2.1.7 decorator-4.4.0 joblib-0.13.2 librosa-0.6.1 llvmlite-0.28.0 numba-0.43.1 numpy-1.16.3 resampy-0.2.1 scikit-learn-0.21.1 scipy-1.3.0 six-1.12.0

shkim at csdl-nano1 in ~ $
→ python3
Python 3.6.7 (default, Oct 22 2018, 11:32:17)
[GCC 8.2.0] on linux
Type “help”, “copyright”, “credits” or “license” for more information.

import librosa
Traceback (most recent call last):
File “”, line 1, in
File “/home/shkim/.local/lib/python3.6/site-packages/librosa/init.py”, line 12, in
from . import core
File “/home/shkim/.local/lib/python3.6/site-packages/librosa/core/init.py”, line 104, in
from .time_frequency import * # pylint: disable=wildcard-import
File “/home/shkim/.local/lib/python3.6/site-packages/librosa/core/time_frequency.py”, line 10, in
from …util.exceptions import ParameterError
File “/home/shkim/.local/lib/python3.6/site-packages/librosa/util/init.py”, line 69, in
from .matching import * # pylint: disable=wildcard-import
File “/home/shkim/.local/lib/python3.6/site-packages/librosa/util/matching.py”, line 16, in
@numba.jit(nopython=True)
File “/home/shkim/.local/lib/python3.6/site-packages/numba/decorators.py”, line 174, in wrapper
**dispatcher_args)
File “/home/shkim/.local/lib/python3.6/site-packages/numba/dispatcher.py”, line 541, in init
self.targetctx = self.targetdescr.target_context
File “/home/shkim/.local/lib/python3.6/site-packages/numba/targets/registry.py”, line 50, in target_context
return self._toplevel_target_context
File “/home/shkim/.local/lib/python3.6/site-packages/numba/utils.py”, line 357, in get
res = instance.dict[self.name] = self.func(instance)
File “/home/shkim/.local/lib/python3.6/site-packages/numba/targets/registry.py”, line 34, in _toplevel_target_context
return cpu.CPUContext(self.typing_context)
File “/home/shkim/.local/lib/python3.6/site-packages/numba/targets/base.py”, line 250, in init
self.init()
File “/home/shkim/.local/lib/python3.6/site-packages/numba/compiler_lock.py”, line 32, in _acquire_compile_lock
return func(*args, **kwargs)
File “/home/shkim/.local/lib/python3.6/site-packages/numba/targets/cpu.py”, line 47, in init
self._internal_codegen = codegen.JITCPUCodegen(“numba.exec”)
File “/home/shkim/.local/lib/python3.6/site-packages/numba/targets/codegen.py”, line 608, in init
self._init(self._llvm_module)
File “/home/shkim/.local/lib/python3.6/site-packages/numba/targets/codegen.py”, line 613, in _init
target = ll.Target.from_triple(ll.get_process_triple())
File “/home/shkim/.local/lib/python3.6/site-packages/llvmlite/binding/targets.py”, line 195, in from_triple
raise RuntimeError(str(outerr))
RuntimeError: Unable to find target for this triple (no targets are registered)

JETSON NANO : When tried to import numba and got below issue.
RuntimeError: Unable to find target for this triple (no targets are registered)

Kernal report : $ uname -m -p -i -o
aarch64 aarch64 aarch64 GNU/Linux

$ file -L which python
python: ELF 64-bit LSB executable, ARM aarch64, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-aarch64.so.1, for GNU/Linux 3.7.0, BuildID[sha1]=d627ef878f18bc969e1914564d7a2c095c310c6d, stripped

cmake command:
sudo cmake llvm-10.0.1.src/ -DLLVM_TARGETS_TO_BUILD=“ARM” -DLLVM_TARGET_ARCH=ARM -DLLVM_DEFAULT_TARGET_TRIPLE=armv8-linux-gnueabihf -DLLVM_USE_LINKER=gold -DCMAKE_BUILD_TYPE=“Release”

Python version:

import llvmlite
llvmlite. version
’0.34.0’

Python 3.6.9 (default, Jul 17 2020, 12:50:27)
[GCC 8.4.0] on linux
Type “help”, “copyright”, “credits” or “license” for more information.

from llvmlite import binding as ll
print(ll.get_process_triple())
aarch64-unknown-linux-gnu
print(tuple. itemsize )
8

Any help appreciated ! Thanks

Hi dhgokul,

Please help to open a new topic for this issue. Thanks