required glibc version

I have PGI 13.7 Accelerartor Fortran installed under Open SUSE 11.4 w/glibc 2.6.1. The compiler works, but we did not check cuda-5.0-based extensions.

According 13.7 Installation Guide even SuSE 9.3 w/glibc 2.3.4 must work w/compiler.
But yesterday I tried to install CUDA 5.0 Toolkit Samples and it says that glibc 2.14 is required for example for some libcudart.so modules.

What is really about glibc requirements for 13.7 cuda-based extensions ?

Mikhail

Hi Mikhail,

The CUDA Toolkit is a separate and may have differing requirements than the PGI Fortran compilers.

PGI ships all necessary components to build CUDA Fortran. There was a problem in 13.7 on older systems when targeting CUDA 5.0 due to a header file issue, but this was fixed in 13.9 when we moved to CUDA 5.0 by default. Of course, if you are unable to install the CUDA 5.0 drivers on your system, then any CUDA Fortran program built using CUDA 5.0 wont run.

  • Mat

Yes, I understand that CUDA is different product. But I’m afraid potentially different requirements of PGI CUDA Fortran and corresponding CUDA version itself. Should I understand you that there is no requirements of glibc 2.4 or higher from PGI 13.7 (or even 13.9) ?

New NVIDIA kernel driver (nvidia.ko) was installed independently. It looks that it works OK (nvidia-smi works successfully).
But what is about OGI CUDA Fortran glibc requirement ?

Mikhail

Hi Mikhail,

For PGI components, you can find out which Linux versions are supported by which compiler versions at: http://www.pgroup.com/support/install.htm#linux_info.

Non-PGI components, such as CUDA and ACML, may have different requirements. However, in the case of CUDA, this is one reason why we ship multiple versions of the tool kit.

  • Mat

OpenSuSE 11.2 and 12.2 are supported.
I have 11.4 (where PGI 13.7 w/cuda extension is installed) and new HDD w/12.3, where PGI isn’t installed - but potentially I may move it to this HDD.
Is this supported Linux list for whole product - i.e. for PGI Fortran w/CUDA extensions ? If the answer is “yes”, my glibc version in SUSE 11.4 is higher than in officially supported 11.2, and practically PGI 13.7 w/cuda extensions must work.

If “no”, are glibc requirements found by me for cuda toolkit 5.0 Samples under OpenSuSE 11.4 important for PGI cuda components ?

It’s the question not about CUDA - it’s the question for whole PGI product I purchased.


There is no clear system requirements for CUDA.
I installed on new HDD on server w/K20c and OpenSUSE 12.3
:CUDA 5.5 (Toolkit works including Samples) - but PGI is based on 5.0

:CUDA 5.0 (toolkit was installed after suppressing of some checks - including gcc, but Samples reject gcc 4.7 as unsupported and don’t works)

I don’t know, shold I pay attention on cuda Samples for PGI fortran w/cuda ??
Unfortunately I myself can’t check 13.7 installed for work w/cuda extensions - I’m not familiar with this features.

Thanks for help !
Mikhail

Hi Mikhail,

I think the best thing for you to do is to install PGI 13.9 on the new system since it includes CUDA 5.5. The default CUDA using is 5.0, so you’ll need to add the flag “-Mcuda=5.5”.

  • Mat