Riva eror during rivainit cannot download models

Please provide the following information when requesting support.

Hardware - GPU rtx 3060
Hardware - CPU i7
Operating System windows 10
Riva Version 1.5 beta
TLT Version (if relevant)
How to reproduce the issue ? (This is for errors. Please share the command and the detailed log here)

$ winpty bash riva_init.sh
Logging into NGC docker registry if necessary…
Pulling required docker images if necessary…
Note: This may take some time, depending on the speed of your Internet connection.

Pulling Riva Speech Server images.
Image nvcr.io/nvidia/riva/riva-speech:1.5.0-beta-server exists. Skipping.
Image nvcr.io/nvidia/riva/riva-speech-client:1.5.0-beta exists. Skipping.
Image nvcr.io/nvidia/riva/riva-speech:1.5.0-beta-servicemaker exists. Skipping.

Downloading models (RMIRs) from NGC…
Note: this may take some time, depending on the speed of your Internet connection.
To skip this process and use existing RMIRs set the location and corresponding flag in config.sh.
docker: Error response from daemon: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: Running hook #0:: error running hook: exit
status 1, stdout: , stderr: nvidia-container-cli: initialization error: driver error: failed to process request: unknown.
Error in downloading models.

Hi @akshit.r.ireddy ,
Can you please check if the host machine has nvidia-docker setup?
Please share teh output of the command with us.
sudo docker run --rm --gpus all nvidia/cuda:11.0-base nvidia-smi


i tried the command and got this error
$ sudo docker run --rm --gpus all nvidia/cuda:11.0-base nvidia-smi
bash: sudo: command not found

i’m using windows 10. i think windows doesn’t have sudo command.
i then tried using ‘runas’ which i think is equivalent to sudo and got no output

Hi @akshit.r.ireddy ,
Apologies for missing that out.
Currently we dont have windows support available and Riva requires Linux to work with .

1 Like