RmInitAdapter Failed - Dell XPS 9500 Laptop

I’ve been unable to get the GeForce 1650 Ti card working on my Dell XPS 9500 laptop running Ubuntu. I understand that this is an Optimum laptop. nvidia-smi returns “No devices were found” and the syslog contains RmInitAdapter failed in many places. This has been going on for quite some time and I’ve tried several versions of the driver and various solutions suggested here and else where (which I haven’t done a good job at documenting). All to no avail.

I recently did a fresh install of Ubuntu 22.04 with the same results, then did a fresh install of Ubuntu 20.04 with the same results again. The BIOS is up to date. Any help is appreciated.

The result of nvidia-smi is:

$ sudo nvidia-smi
No devices were found

I’m currently using the 470 driver from the ubuntu repository. It was installed using Ubuntu’s “Additional Drivers” GUI.

The Nvidia bug report is here:
nvidia-bug-report.log.gz (299.2 KB)

System information:

$ uname -a
Linux stefan-XPS-15-9500 5.14.0-1034-oem #37-Ubuntu SMP Tue Apr 19 14:13:20 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

(Note that I’ve also tried the “stock” kernel as well)

$ lspci | grep -i nvidia
01:00.0 3D controller: NVIDIA Corporation Device 1f95 (rev a1)

And the installed nvidia packages are:

$ apt list --installed | grep nvidia

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libnvidia-cfg1-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
libnvidia-common-470/focal-updates,focal-updates,focal-security,focal-security,now 470.103.01-0ubuntu0.20.04.1 all [installed,automatic]
libnvidia-compute-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
libnvidia-compute-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 i386 [installed,automatic]
libnvidia-decode-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
libnvidia-decode-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 i386 [installed,automatic]
libnvidia-encode-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
libnvidia-encode-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 i386 [installed,automatic]
libnvidia-extra-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
libnvidia-fbc1-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
libnvidia-fbc1-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 i386 [installed,automatic]
libnvidia-gl-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
libnvidia-gl-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 i386 [installed,automatic]
libnvidia-ifr1-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
libnvidia-ifr1-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 i386 [installed,automatic]
nvidia-compute-utils-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
nvidia-dkms-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
nvidia-driver-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed]
nvidia-kernel-common-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
nvidia-kernel-source-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
nvidia-prime/focal-updates,focal-updates,now 0.8.16~ all [installed,automatic]
nvidia-settings/focal-updates,now 470.57.01-0ubuntu0.20.04.3 amd64 [installed,automatic]
nvidia-utils-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]
xserver-xorg-video-nvidia-470/focal-updates,focal-security,now 470.103.01-0ubuntu0.20.04.1 amd64 [installed,automatic]

Please check if switching to the 5.4 kernel makes it work
sudo apt install --install-recommends linux-generic
otherwise, please check with a 460 driver.

Please excuse my ignorance, but how do I switch to using a 460 driver? In the Ubuntu “Additional drivers” GUI, nvidia-driver-460 is not an option. I’ve added the graphics-driver ppa, but I’m still not given the option to install the 460 driver.

Sorry, looks like Ubuntu removed the 460 driver. Did you already try using the 5.4 kernel?

Thanks for the response, generix.

I have have tried both the 510 and the 470 driver with the 5.4 kernel and nvidia-smi still reports “No devices were found” in both cases.

Then I guess it’s simply broken. Please install Windows and check if you’re gettin Code 43 in device manager to double-check.