RPi HQ camera + PWM output

I am not able to use CSI camera and PWM at the same time.
I have successfully configured Jetson Nano to use the RPi HQ camera module using ArduCAM driver


However, I am encountering problems using the PWM output on pin 33.
I am able to configure the PWM output using /opt/nvidia/jetson-io/jetson-io.py script, but whenever I load the camera driver PWM settings are set to default.
Can anybody give some suggestions on where to start to solve this problem?

hello Edwin2087,

this might caused by that pin is occupied by the camera driver.
could you please review the power sequence of RPi HQ camera.
thanks

I have checked the Arducam modified tegra210-p3448-0000-p3449-0000-b00.dtb file and didn’t found the 40-Pin Expansion Header configuration, so it looks like the camera is not using the pin PE6 (header pin 33). However, my configured tegra210-p3448-0000-p3449-0000-b00-user-custom.dtb has section “header-40pin-pinmux”.

pin33 {
                nvidia,enable-input = <0x00000000>;
                nvidia,tristate = <0x00000000>;
                nvidia,pull = <0x00000000>;
                nvidia,pins = "pe6";
                nvidia,function = "pwm2";
            };

Is there a way to add or merge the *.dtb file 40-Pin header configuration together with the camera configuration?

hello Edwin2087,

you may include those changes and recompile the dtb file for usage.
please also refer to Kernel Customization chapter for building the NVIDIA kernel.
thanks