RTSP glitch in deepstream app

Please provide complete information as applicable to your setup.

**• Hardware Platform = Jetson **
• DeepStream Version = 5.1
• JetPack Version = 4.5.1
• TensorRT Version = 7.1.3
• Issue Type = question and bug

Hi. I’m working with RTSP streams in deepstream-app or deepstream-test5-app and I’m getting glitches in the RTSP stream. I have followed the guidelines and also followed some forums which suggested the following.

  1. Streammux and primary-gie batch size should be same as that of the number of RTSP sources. I tried this but still I’m getting the glitches.

  2. I enabled the NVDS_ENABLE_LATENCY_MEASUREMENT and found the latency of the stream. I added that latency in the [sourcex] group as i have a property named as latency. This also failed.

I also tried by increasing and decreasing the batch size for streammux and primary-gie but it didn’t helped me.

How can i avoid the glitching of RTSP stream in the deepstream application?

Please try this:
deepstream4.0 with rtsp of sink makes the picture distortion with high bitrate - #9 by DaneLLL

And may try to disable primary-gie to check if the issue happens without running deep learning inferences.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.