RTSP stream not recognizing USB camera


I have a USB camera connected to my nano, my main goal is to create an RTSP stream so that I can access the camera from my website.
I have the camera connected via USB to my nano, and the camera functions when called via gstreamer using dev/video0, however when I try to create an RTSP to access the camera I get a color block and the camera is not streaming. I’ve tried using VLC as well, and still no luck.

I’ve tried running the RTSP with the lo IP as well as the wlan0 IP.

The guide I followed was the Jetson Nano FAQ: Jetson Nano FAQ

Any possible suggestions would be really appreciated!! Thank you!

On Jetpack 4.5.1(r32.5.1), we are able to run RTSP server on Jetson Nano + AverMedia CAM513. Please refer to the commands:

$ sudo jetson_clocks
$ ./test-launch "v4l2src device=/dev/video1 ! video/x-raw,width=1920,height=1080,framerate=30/1,format=UYVY ! nvvidconv ! video/x-raw(memory:NVMM),format=NV12 ! nvv4l2h264enc ! h264parse ! rtph264pay name=pay0 pt=96"

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.