RTX 3090 RTX 3060 TI 6 monitors Debian 12

I have recently switched over from Windows to Debian 12, unfortunately upon installation of the NVIDIA drivers the three monitors hooked up to the 3060 TI fail to display anything but a black screen. I have tried a couple solutions yet still nothing. For example
delete xorg.conf
set kernel parameter nvidia-drm.modeset=1
check two nvidia providers are avalable
run xrandr --setprovideroutputsource NVIDIA-G0 NVIDIA-0 && xrandr --auto

After running the last command I receive the error: configure crtc 4 failed
The only solution which seems to work is running the OS without the NVIDIA drivers, however, there’s a noticeable performance difference when doing so. Is there any other possible solutions to this problem I can try? I can provide whatever information needed to better assist those who seek to help me with this problem, however, please excuse my ignorance as I’m very new to the whole Linux ecosystem.

The error message would usually point to the kernel/module parameter not properly set.
Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.
Please post the output of

sudo cat /sys/module/nvidia_drm/parameters/modeset

Thank you for your response, here is that file.

nvidia-bug-report.log.gz (628.9 KB)

Please set kernel parameter nvidia-drm.modeset=1
and post the output of

sudo cat /sys/module/nvidia_drm/parameters/modeset

after reboot.

Sorry for not rebooting in the prior bug report. Here is the new file with reboot after setting the kernel parameter.

nvidia-bug-report.log.gz (613.2 KB)

The parameter is still not set, did you forget to run
sudo update-grub

My apologies, I didn’t realize I had to run sudo update-gurb
After running the command I got this response

Generating grub configuration file …
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-6.1.0-17-amd64
Found initrd image: /boot/initrd.img-6.1.0-17-amd64
Found linux image: /boot/vmlinuz-6.1.0-15-amd64
Found initrd image: /boot/initrd.img-6.1.0-15-amd64
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.

Here is the new bug report file
nvidia-bug-report.log.gz (650.5 KB)

Still not set. How did you add it?

Am I supposed to be running the line set kernel parameter nvidia-drm.modeset=1 in the terminal? That’s what I’ve been doing, maybe this is incorrect?

No, it’s not a command but a config setting, please add it like this:

It worked! Thank you so much for all the help, I truly appreciate it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.