RTX 4090 not visible in Ubuntu 22.04 on Dell Alienware m18

I have just received my new Dell Alienware m18 with an RTX4090 and I run it under Ubuntu 22.04 LTS. When I type “lspci | grep -i NVIDIA” in the terminal it doesn’t see my GPU despite the fact that I typed “sudo update-pciids” before. I join the bug report that I generated. Could you please help ?
nvidia-bug-report.log.gz (395.2 KB)

Hi thierry-arlandis,

I am not sure what to say, but if I check the log I find this:

/usr/bin/lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation Device [8086:a702] (rev 01)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GN21-X11 [10de:2757] (rev a1)

and the nvidia-smi --query also looks completely normal

/usr/bin/nvidia-smi --query

==============NVSMI LOG==============

Timestamp                                 : Mon Oct 30 20:57:37 2023
Driver Version                            : 535.113.01
CUDA Version                              : 12.2

Attached GPUs                             : 1
GPU 00000000:01:00.0
    Product Name                          : NVIDIA GeForce RTX 4090 Laptop GPU
    Product Brand                         : GeForce
    Product Architecture                  : Ada Lovelace
    Display Mode                          : Enabled
    Display Active                        : Enabled

Maybe a typo when you tried lspci?

Hi Markus

Thanks for your quick reply, no typo I tried again but the strange thing is that I have just installed CUDA 12.3, CUDNN and run Yolov4 on this PC and it is working correctly at about 49Hz average, which means that the it finds the RTX4090. It’s a mystery.

The return from lspci | grep -i NVIDIA is
01:00.0 VGA compatible controller: NVIDIA Corporation GN21-X11 (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 22bb (rev a1)

I don’t know what to say.

Well, no worries, glad to hear things are working now.

Who knows what happened there.